Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

A little background: We converted our S3-backed (instance-store) AMI to an EBS-backed AMI recently. The process basically equated to:

  1. Stop the server
  2. Image the filesystem using ec2-bundle-image
  3. rsync that image onto a new EBS volume (excluding several directories: --exclude=/root/.bash_history --exclude=/home/*/.bash_history --exclude=/etc/ssh/ssh_host_* --exclude=/etc/ssh/moduli --exclude=/etc/udev/rules.d/*persistent-net.rules --exclude=/mnt/* --exclude=/proc/* --exclude=/tmp/* --exclude=/sys/* --exclude=/dev/*
  4. cd to the EBS volume's /dev
  5. run for i in console null zero pty; do MAKEDEV $i; done
  6. create a snapshot of that EBS volume in the AWS management console
  7. create an AMI from the EBS snapshot
  8. launch this new AMI

The new AMI I created does boot, correctly serves our websites, and is reachable by ssh. However, I've recently tried to mount an EBS volume with some MP3s on this new instance, and I'm getting errors -- namely:

# mount -t ext3 /dev/sdp /production
mount: /dev/sdp is not a valid block device

I have since run MAKEDEV sd in /dev and tried again to mount it, with no luck.

EDIT: Wow, I made a dumb mistake. the correct command to mount this volume is mount -t ext3 /dev/sdp1 /production. That said, I would still like information about these errors in the startup log, as they worry me.

There's a full paste of the log I copy-pasted from Amazon's AWS management console here: http://pastebin.com/NCvzQyum

The lines that concern me are the following:

139-143:

Mount failed for selinuxfs on /selinux: No such file or directory

modprobe: FATAL: Could not load /lib/modules/2.6.16-xenU/modules.dep: No such file or directory

modprobe: FATAL: Could not load /lib/modules/2.6.16-xenU/modules.dep: No such file or directory

149-159:

/proc is empty (not mounted ?)

hostname: the specified hostname is invalid udev requires a kernel >= 2.6.18, not started.

[31mfailed!
[39;49m

[31mfailed!
[39;49m

Mount point '/dev/shm' does not exist. Skipping mount.
[33m(warning).
[39;49m

171-177:

Mounting local filesystems...mount: special device /dev/sda2 does not exist
mount: mount point /production does not exist
mount: none already mounted or /sys busy
mount: according to mtab, sysfs is already mounted on /sys

[31mfailed.
[39;49m

The last one, at 204-206, is familiar. We're using Amazon RDS so we don't need a local mysql daemon, and I'm aware that the root device is too full -- and I'll be fixing that anyway.

Thanks in advance to anyone who tries to help out!

share|improve this question
1  
A quick glance over the issues seems to divide them into two groups - mount issues and modprobe issues. For the mount issues, take a look at /etc/fstab - see that you have the necessary entries, and don't have duplicates. For the modprobe issues, you seem to be missing a kernel module - either extracting those provided by alestic to /lib/modules/ and running depmod or try a different kernel (AKI). As a side observation, some packages (kernel 2.6.16, gcc 4.0.2, RHEL 4, etc) listed seem a bit dated (2006?). –  cyberx86 Jan 24 '12 at 1:49
    
Thanks for the info. You are correct that some packages are probably old -- with regards to that I'm still somewhat of a n00b. apt-get update doesn't upgrade all that low-level stuff... :sigh: any simple solution for keeping this stuff updated? –  Felixander Weber Jan 24 '12 at 4:55
    
Your package manager really should do that. What OS? You mention apt-get (Debian/Ubuntu?) - but your boot log mentions Red Hat (uses yum). Both provide kernel updates, etc from their repositories (upgrade the entire OS a later version?). EC2 has only been out of beta since 2008 - so, especially for a new setup, seeing 2006 stuff is strange. If your setup isn't too complex, you might consider using Amazon's Linux AMI (their official distribution), installing the software you need, and copying your configurations and data - AWS maintains the repositories and keeps the packages quite up to date. –  cyberx86 Jan 24 '12 at 5:24
    
It's a Debian Lenny instance... I didn't set it up myself, but I've been maintaining it. We've been using EC2 for quite a while actually -- not sure how to check exactly but definitely at least 2-3 years. I have no idea where the RH/yum stuff came from, but I'm looking into the unattended-upgrades package now. Thanks again. –  Felixander Weber Jan 24 '12 at 5:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.