Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Can't get an HP 8200 Elite Small Form Factor to boot from USB. It's done so in the past & the USB boot drive works in a different machine (HP 8440p laptop).

Have tried upgrading BIOS (from 2.09 to 2.15a, then back to 2.14a) with no luck.

USB drive appears in BIOS "Device Configuration" list, but not in "Boot Order". USB Hard Drive is set highest in the BIOS "Boot Order" list.

What simple, obvious thing am I missing here?

share|improve this question

4 Answers 4

up vote 2 down vote accepted

The 8200 uses UEFI, not traditional BIOS; in the Boot Order menu, there are submenus titled "EFI Boot Sources" and "Legacy Boot Sources".

One method for USB booting this machine is to disable the EFI boot sources and enable USB Floppy/CD under Legacy boot sources; we're using the Legacy Boot option to set PXE network boot. It should also possible with an EFI-configured USB drive, but I've not tested that.

share|improve this answer
    
Sorry, I'm old and refer to everything as BIOS - I should know better. I tried disabling the EFI boot sources, but the USB still didn't show up in the F9 boot menu. I went back in and faffed around disabling and re-enabling various things, and at some point, it worked! Not entirely sure what made it work, but appears to be something to do with disabling the EFI boot sources. Thanks very much! –  slag Jan 24 '12 at 4:17
    
Have done some more testing, will post the results as an answer to this question, but can't do this until tomorrow as I don't have a good enough ServerFault reputation yet! –  slag Jan 24 '12 at 4:34

Update BIOS to 2.23 - problem solved

share|improve this answer
    
Is the fix in version 2.23? –  sysadmin1138 Apr 9 at 11:28
    
updated from 2.01 to 2.25 and USB keys work fine for me –  mindex Dec 15 at 7:54

EDIT 2 - have heard back from HP - there is a note in the Release Notes for versions from 2.09 on saying you need to Apply Defaults from the File menu in BIOS. This fixed the problem.

It's only required for machines that have been upgraded from a pre-2.09 version - those delivered with 2.09 or higher will already have this done.

EDIT - I've struck this problem with BIOS firmware 2.14 & 2.15, but going to the next version back (2.06) results in success. Still not a fix as we need the higher BIOS level to overcome a USB keyboard/mouse lockout problem during preboot.

Further testing reveals the following:

  • it doesn't seem to matter whether or not EFI Boot Sources are enabled
  • disabling (F5) and re-enabling (F5 again) "Hard Drive" under "Legacy Boot Sources" in the Boot Order seems to make the USB key available as a boot device under the F9 menu
  • unplugging the USB key, rebooting, then plugging the USB key back in results in the USB key no longer being available in the F9 menu, so not being able to boot off it. Disabling and re-enabling the Hard Drive as a boot source, as in the step above, is then required in order to see the USB key in the F9 menu again

So, a workaround, but a painful one when we have 500+ machines to image. Might have to sort out PXE.

Will probably report this to HP as well, see if they can replicate it.

Same problem occurs with two totally different USB keys, with the same workaround.

share|improve this answer
1  
You're imaging 500 desktops with USB sticks? Sounds like a lot of work compared to PXE. Also out of curiosity; what kind of imaging software is this? –  pauska Jan 25 '12 at 1:50
    
This is what did the trick for me. I had upgraded the BIOS on an 8200 Elite from 2.01 to 2.24 and then lost the ability to boot to USB. Entering the BIOS and selecting Apply Defaults from the File menu made all of my USB drives show up again in the Boot Menu. Thanks for the help. –  pmerchant73 Mar 6 at 18:51

The solution is:

In Boot Order Menu set USB Floppy/CD item to the end of list

And Hard Drive Boot item must be the first item in list

share|improve this answer
    
@slag told in his question, that the entry is missing in the boot order menu. –  Thomas Berger Oct 17 '12 at 12:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.