Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have 2 Cisco routers and they are connected via GRE over IPsec.
All of the traffic from the first router is being routed to the 2nd router with a default route.
I need to access internet from the 2nd router.

How should I config the NAT on the 2nd router so that the clients behind the 1st router can access the internet from the 2nd router?

share|improve this question

1 Answer 1

I just tested it in dynamips and it seems to work fine.

interface Tunnel0
 ip address 192.168.100.1 255.255.255.252
 ip nat inside
 ip virtual-reassembly
 tunnel source Serial0/0
 tunnel destination 192.168.1.2
 crypto map vpn
!
interface Serial0/1
 ip address 201.5.12.1 255.255.255.252
 ip nat outside
 serial restart-delay 0
!
ip route 172.16.1.0 255.255.255.0 192.168.100.2
ip nat inside source list 10 interface Serial0/1 overload
access-list 10 permit 172.16.1.0 0.0.0.255

source

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.