Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Having a problem with the --message flag to the svn import command. On some servers it works, but on others it gets confused if the message contains spaces, even if you single or double quote the message string thus:

    svn import -m 'New stuff added' https://my-remote-repo/SVN/repo/path

When it fails, I get the error:

    svn: Too many arguments to import command

If I limit the message to one without any spaces, it succeeds everytime. Clearly the problem is with the command failing to recognise a quoted string, but why?

Differences between whether it succeeds or not seems to be down to the particular OS/Shell combination I'm using. The command works on SUSE 10.3 with Ksh Version M 93s+ 2008-01-31, but fails on RHEL 5.6 with Ksh Version AJM 93t+ 2010-02-02. Or perhaps that's a red herring, and the real problem is something else differing between environments?

share|improve this question
    
Did you try writing -m option at the end of the command? –  Khaled Jan 24 '12 at 11:34
    
Yes, unfortunately makes no difference. –  RCross Jan 24 '12 at 11:38
2  
tried replacing ' with " ? –  Ivan Jan 24 '12 at 14:09
    
Try type -a svn and compare the results. I would suspect a badly written alias, function or script which accepts the argument then passes it along without quoting it. –  Dennis Williamson Jan 26 '12 at 17:01
add comment

1 Answer

You can use this syntax in ksh: svn "import -m 'New stuff added' https://my-remote-repo/SVN/repo/path"

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.