Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Having a problem with the --message flag to the svn import command. On some servers it works, but on others it gets confused if the message contains spaces, even if you single or double quote the message string thus:

    svn import -m 'New stuff added' https://my-remote-repo/SVN/repo/path

When it fails, I get the error:

    svn: Too many arguments to import command

If I limit the message to one without any spaces, it succeeds everytime. Clearly the problem is with the command failing to recognise a quoted string, but why?

Differences between whether it succeeds or not seems to be down to the particular OS/Shell combination I'm using. The command works on SUSE 10.3 with Ksh Version M 93s+ 2008-01-31, but fails on RHEL 5.6 with Ksh Version AJM 93t+ 2010-02-02. Or perhaps that's a red herring, and the real problem is something else differing between environments?

share|improve this question
Did you try writing -m option at the end of the command? – Khaled Jan 24 '12 at 11:34
Yes, unfortunately makes no difference. – RCross Jan 24 '12 at 11:38
tried replacing ' with " ? – Ivan Jan 24 '12 at 14:09
Try type -a svn and compare the results. I would suspect a badly written alias, function or script which accepts the argument then passes it along without quoting it. – Dennis Williamson Jan 26 '12 at 17:01

You can use this syntax in ksh: svn "import -m 'New stuff added' https://my-remote-repo/SVN/repo/path"

share|improve this answer

I just ran into this problem myself and stumbled upon this question. I didn't find the answer here, but played around with it a little and was able to get it to work.

I was writing my svn import with an asterisk like this:

svn import * svn:// -m 'Initial Import'

When I changed the star to a dot, it worked as expected.

svn import . svn:// -m 'Initial Import'

In your case, you do not seem to be specifying a dot or a star or anything. I'm willing to bet that's why it's getting tripped up.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.