Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am struggling to get my WDS answer file to delete the existing disk partition, re-create it and install the os to it. I'm installing windows 7. All my other settings are working fine, its just this i'm struggling with.

I'm also a bit confused as to which unattended file to put the disk setting in, does it need to go in the client xml file or the image one? This is the setting i have tried that is having no effect.

<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="XXXXXXXXXXX" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
        <ImageInstall>
            <OSImage>
                <InstallTo>
                    <DiskID>0</DiskID>
                    <PartitionID>1</PartitionID>
                </InstallTo>
                <WillShowUI>OnError</WillShowUI>
            </OSImage>
        </ImageInstall>
        <DiskConfiguration>
            <Disk wcm:action="add">
                <CreatePartitions>
                    <CreatePartition wcm:action="add">
                        <Order>1</Order>
                        <Size>100</Size>
                        <Type>Primary</Type>
                    </CreatePartition>
                    <CreatePartition wcm:action="add">
                        <Extend>true</Extend>
                        <Order>2</Order>
                        <Type>Primary</Type>
                    </CreatePartition>
                </CreatePartitions>
                <ModifyPartitions>
                    <ModifyPartition wcm:action="add">
                        <Active>true</Active>
                        <Extend>false</Extend>
                        <Format>NTFS</Format>
                        <Label>System</Label>
                        <Order>1</Order>
                        <PartitionID>1</PartitionID>
                    </ModifyPartition>
                    <ModifyPartition wcm:action="add">
                        <Format>NTFS</Format>
                        <Label>Windows</Label>
                        <Letter>C</Letter>
                        <Order>2</Order>
                        <PartitionID>2</PartitionID>
                    </ModifyPartition>
                </ModifyPartitions>
                <DiskID>0</DiskID>
                <WillWipeDisk>true</WillWipeDisk>
            </Disk>
            <WillShowUI>OnError</WillShowUI>
        </DiskConfiguration>
    </component>
share|improve this question

1 Answer 1

up vote 1 down vote accepted

This post is a little old, however if you still need help or to help others in this situation...

Download and install the Microsoft Deployment Toolkit (MDT)(it's free). MDT will integrate with WDS and will make many things easier. In particular, once you have setup a task sequence for your deployment, open the task and go to the Task Sequence tab, then navigate to the Preinstall section, and open the New Computer Only section and you will see the settings to Format and Partition the hard drive. MDT has already set it to format and partition for you. More information on MDT can be found on the MDT page on TechNet.

share|improve this answer
1  
i did end up using MDT thanks anyway –  beakersoft Mar 8 '12 at 15:44
    
Great! Glad you had solved it. –  WinOutreach4 Mar 8 '12 at 16:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.