Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This doesn't work for me:

# iptables -A INPUT -p tcp --dports 110,143,993,995 -j ACCEPT

iptables v1.4.7: unknown option `--dports'
Try `iptables -h' or 'iptables --help' for more information.

However in the man page, there is an option --dports... any ideas?

share|improve this question
4  
Quick guess would be that you need to use the multiport module: -m multiport --dports 110,143,993,995 ... –  cyberx86 Jan 24 '12 at 15:55
    
@cyberx86 Yes are right :) Thanks! –  Zenet Jan 24 '12 at 15:57
add comment

2 Answers 2

up vote 4 down vote accepted

You have to use --match multiport in the rule for defining more ports

#iptables -A INPUT -p tcp  --match multiport --dports 110,143,993,995 -j ACCEPT
share|improve this answer
add comment

You need to specify the -m multiport module before using the dports options

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.