Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Quick example:

~ $ wor<TAB>
~ $ WORDCHARS=                                                                                                                                                                                                             
WORDCHARS    WORKON_HOME  WORKON_HOME  workon 

workon is the desired command. Is there a way to exclude the environment variables from auto-completing in ZSH?

share|improve this question
up vote 3 down vote accepted

I didn't find such an option, but maybe you are helped, if your completion would be case sensitive. you can set this in your ~/.zshrc:

# Set to this to use case-sensitive completion
CASE_SENSITIVE="true" 
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.