Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have enabled Client Certificate Authentication for Exchange 2010 through IIS7 and the users are prompted to choose their User Certificate when they log in, but they are all then presented with the following error message

Request Url: https://<domain_name>:443/owa/ User host address: <server_ip_address> OWA version: 14.1.355.2

Exception Exception type: System.NullReferenceException Exception message: Object reference not set to an instance of an object.

Call stack

Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.GetUserIdentities(OwaContext owaContext, OwaIdentity& logonIdentity, OwaIdentity& mailboxIdentity, Boolean& isExplicitLogon, Boolean& isAlternateMailbox, ExchangePrincipal& logonExchangePrincipal) Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.InternalDispatchRequest(OwaContext owaContext) Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchRequest(OwaContext owaContext) Microsoft.Exchange.Clients.Owa.Core.OwaRequestEventInspector.OnPostAuthorizeRequest(Object sender, EventArgs e) System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

The method I followed to enable Certificate authentiaction was from this post:

http://www.miru.ch/2011/04/how-to-enable-certificate-based-authentication-on-exchange-2010/

Any ideas? Google isn't being very helpful

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

The fix was simple, you just need to search for <authentication mode="Form"/> in the web.config file and change it to Windows (capital W)

The authentication type specified in the

C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\owa\web.config file is incorrect. The correct authentication type is "Windows".

share|improve this answer
    
What is the OWA authentication mode set to in EMC? Exchange has a tendency to overwrite manually configured values... –  Trondh Sep 4 '13 at 10:56
    
This is a little while ago amigo! I cant remember :) –  Christian Sep 4 '13 at 20:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.