Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been trying to install Mono on CentOS 5.5 with Cpanel. It was all going fine until I needed to install the mod mono add-on. I get a missing dependency error, any help would be much appreciated thanks.

Tryining to install mod mono:

root@ns223540 [~]# yum install mod_mono-addon              
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.ovh.net
 * epel: mirror.ibcp.fr
 * extras: mirror.ovh.net
 * updates: mirror.ovh.net
Excluding Packages in global exclude list
Finished
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package mod_mono-addon.i386 0:2.10-6.9 set to be updated
--> Processing Dependency: httpd >= 2.2 for package: mod_mono-addon
---> Package mod_mono-addon.x86_64 0:2.10-6.9 set to be updated
--> Processing Dependency: httpd >= 2.2 for package: mod_mono-addon
--> Finished Dependency Resolution
mod_mono-addon-2.10-6.9.x86_64 from Mono has depsolving problems
--> Missing Dependency: httpd >= 2.2 is needed by package mod_mono-addon-2.10-6.9.x86_64 (Mono)
mod_mono-addon-2.10-6.9.i386 from Mono has depsolving problems
--> Missing Dependency: httpd >= 2.2 is needed by package mod_mono-addon-2.10-6.9.i386 (Mono)
Error: Missing Dependency: httpd >= 2.2 is needed by package mod_mono-addon-2.10-6.9.i386 (Mono)
Error: Missing Dependency: httpd >= 2.2 is needed by package mod_mono-addon-2.10-6.9.x86_64 (Mono)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                    package-cleanup --dupes
                    rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Check httpd verison

root@ns223540 [~]# rpm -q httpd              
package httpd is not installed

Try to install httpd

root@ns223540 [~]# yum install httpd
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.ovh.net
 * epel: mirror.ibcp.fr
 * extras: mirror.ovh.net
 * updates: mirror.ovh.net
Excluding Packages in global exclude list
Finished
Setting up Install Process
No package httpd available.
Nothing to do
share|improve this question
add comment

1 Answer

If you use cPanel I think you need to use easyapache. If you still want to use yum then you need to check your /etc/yum.conf if httpd is not listed in the exclude line! Remove it from there and use yum to install httpd

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.