Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I noticed this appeared recently in our Exchange 2010 upgrade: in certain appointments, the organizer's name will appear with the subject in the appointment. In this case, there is only one person in the appointment (the organizer) and no resources have been allocated. Can the organizer's name be removed from the calendar view?

share|improve this question
    
For the appointment in question - was it created on a shared calendar, like a room or resource calendar? –  Phil Erb Feb 10 '12 at 16:19
    
No, an individual's calendar –  marcwenger Feb 11 '12 at 0:44
    
And just to be clear, the item is on an individual's calendar and the DID NOT also include a conference room or resource calendar in the appointment? –  Phil Erb Feb 11 '12 at 11:56
    
No resources - no rooms –  marcwenger Feb 14 '12 at 3:23

2 Answers 2

It sounds like the user's calendar AutomateProcessing flag is set to AutoAccept, which then checks the AddOrganizerToSubject setting and, if set to true, adds the organizer to the subject as you are experiencing.

The default setting for AutomateProcessing on a user mailbox is AutoUpdate. To check what this setting currently is for the user, run this command in the Exchange Management Shell:

Get-CalendarProcessing [primary_email_address] | Select AutomateProcessing

To set the mailbox back to AutoUpdate for the AutomateProcessing setting, run this command:

Set-CalendarProcessing [primary_email_address] -AutomateProcessing AutoUpdate

More information about the Set-CalendarProcessing command is available at http://technet.microsoft.com/en-us/library/dd335046.aspx

share|improve this answer
    
This might be helpful. More info: I only see the name in the OWA calendar, but not in the Outlook calendar. Are there different calendar processing switches for OWA? –  marcwenger Feb 14 '12 at 6:21
    
I'm not aware of differences between OWA and Outlook for calendar processing switches. The interesting thing is AutoAccept should only work for resource mailboxes, not user mailboxes. Run the command "Get-Mailbox [primary_email_address] | Select RecipientTypeDetails" and let me know what type of mailbox this is showing up as. Also let me know what the "Get-CalendarProcessing" command above returned. I've tried several variations of settings and haven't yet been able to reproduce this issue. –  Phil Erb Feb 14 '12 at 13:43
    
Yes, it is a user mailbox, not a resource (get-mailbox) Autoupdate is on for get-calendarprocessing, with addorganizertosubject set to false –  marcwenger Feb 14 '12 at 20:37
    
Are there any delegates or any other shared permissions on the mailbox in question? You say that the organizer name only appears in the subject when viewing in OWA, not Outlook? Does the owner of the mailbox see the same thing - if they look in OWA is the name there and in Outlook it is not? This appointment was just a normal appointment or was it a meeting request (i.e. sent to other people)? You've definitely stumbled upon an interesting one here. –  Phil Erb Feb 15 '12 at 13:05
    
Correction: it does appear in Outlook (my bad) –  marcwenger Feb 16 '12 at 18:14

Set-CalendarProcessing mailbox -AddOrganizerToSubject $false -deletesubject $false

That will stop Exchange from adding the organizer to the subject, and also stop it from deleting the original subject.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.