Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a domain - myapp.com - hosted by Dream Host. Up until recently I had some php as a signup form at that domain. I also had a one-click install of Word Press at blog.myapp.com, and could log into GMail through Google Apps from Dream Host at mail.myapp.com.

A few days ago I migrated my Rails app over to myapp.com using Heroku's Zerigo add-on. Zerigo worked magic migrating my app over to myapp.com, however blog.myapp.com didn't work, and neither did mail.myapp.com. (I could access mail but I had to go mail.google.com/a/myapp.com. Plus I was having people tell me their emails to me were bouncing back with errors.)

I contacted Dream Host who helped with getting my blog back - they had me use custom DNS by setting the A record with value 173.236.196.13 for blog.myapp.com and www.blog.myapp.com. I did this in Zerigo. The blog was back.

However, I still couldn't access my mail through mail.myapp.com. So I went back to Dream Host and they told me to:

  1. Have MX records set for myapp.com and mail.myapp.com pointing to mx1.sub4.homie.mail.dreamhost.com. and mx2.sub4.homie.mail.dreamhost.com. Priority of 0 (zero) for both.
  2. Set an A record for mail.myapp.com pointing to 208.97.132.231 and another for webmail.myapp.com pointing to 208.97.187.139.

I did all of the above in Zerigo as well and nothing worked. Worse yet, I think my email stopped working. So I removed the MX records for dreamhost, as well as the A records pointing to 208.97.187.139.

So where things currently stand, I have an app that works, a blog that works, but email that I still can't access at mail.myapp.com. And that freaks me out. How can I fix this?

I should note that I'm trying to send mail from my app in SendGrid and GMail (only locally), but have my email accounts and everything else with Google Apps.

I've pasted in all of my Zerigo DNS info below:

myapp.com    174.129.212.2    A    10 minutes   

myapp.com    75.101.145.87    A    10 minutes   

myapp.com    75.101.163.44    A    10 minutes   

myapp.com    aspmx.l.google.com    MX    1    1 hour    

myapp.com    alt1.aspmx.l.google.com    MX    5    1 hour   

myapp.com    alt2.aspmx.l.google.com    MX    5    1 hour   

myapp.com    aspmx2.googlemail.com    MX    10    1 hour    

myapp.com    aspmx3.googlemail.com    MX    10    1 hour    

blog.myapp.com    173.236.196.13    A    10 minutes 

www.blog.myapp.com    173.236.196.13    A    10 minutes 

www.myapp.com    proxy.heroku.com    CNAME    10 minutes
share|improve this question

1 Answer 1

up vote 3 down vote accepted

Thats because you don't have a DNS entry for mail.myapp.com - you will need to create a CNAME record for mail pointing to ghs.google.com

It sounds like you used to have a wildcard record catching each and every subdomain for your site and had it point to dreamhost (this is common for cpanel installations), and when this migration happened, it nuked your wildcard entry, which is why you had to put back your blog DNS entry and point it back to dreamhost.

When you contacted DreamHost about your mail settings, they gave you the settings for their email hosting, not google apps.

share|improve this answer
    
Added the CNAME records and it seems to have worked. Should I put any specific refresh periods on the CNAME? –  tvalent2 Jan 27 '12 at 3:04
    
@tvalent2 - nah, it's highly unlikely that google will change their settings, so a few hours should be fine. Worst case, you'll have to wait a few hours if they ever do change their setup. –  Mark Henderson Jan 27 '12 at 3:09
    
Gotcha, thanks! –  tvalent2 Jan 27 '12 at 4:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.