Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My main objective to to get to install Samba4. But the hangups are ridiculous at this point. Samba 4 is telling me to install BIND 9.8+ So after figuring out the right ./configure I do a make install & now get

named -V
BIND 9.8.1-P1 built with '--with-openssl=/usr' '--sysconfdir=/etc/bind'
    using OpenSSL version: OpenSSL 0.9.8k 25 Mar 2009

Yay , a start - but my daemon that still runs in my /etc/init.d/bind9 is still the 9.7.0 version. I've tried restarting. make distclean & starting again. I've checked my logs and I still get

    Jan 25 23:50:54 hoosier named[25320]: built with '--prefix=/usr' '--mandir=/usr
/share/man' '--infodir=/usr/share/info' '--sysconfdir=/etc/bind' '--localstatedir=/var' 
'--enable-threads' '--enable-largefile' '--with-libtool' '--enable-shared' '--enable-
static' '--with-openssl=/usr' '--with-gssapi=/usr' '--with-gnu-ld' '--with-
dlz-postgres=no' '--with-dlz-mysql=no' '--with-dlz-bdb=yes' '--with-dlz-filesystem=yes' 
'--with-dlz-ldap=yes' '--with-dlz-stub=yes' '--with-geoip=/usr' '--enable-ipv6' 
'CFLAGS=-fno-strict-aliasing -DDIG_SIGCHASE -O2' 'LDFLAGS=-Wl,-Bsymbolic-functions' 
'CPPFLAGS='

I've attempted to repeat that line in my ./configure for the 9.8 version, but then I get errors: @ the gssapi line that it can't find the file; that the -DDIG_SIGCHASE argument isn't recognized; and DLZ isn't on my system.

So my main question is, how do I get the bind9(.7.0) daemon to release control? and grant it to 9.8.2?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It's probably the one that was installed by the bind9 Ubuntu package. Did you replace the named instance binary that the package installed?

Run which named - if it's not pointing to /usr/sbin/named, then the version that the Ubuntu package installed is still there. Replace it or point the init script at the right path for your newly compiled version.

But let's back up a sec - how'd you get down this rabbit hole in the first place? What's wrong with apt-get install samba4, or if that's not new enough, using the PPA (add-apt-repository ppa:samba-team/ppa)?

share|improve this answer
    
I installed this ubuntu + bind ~ 2 years ago. Not doubting its the original package. –  Lee Fisher Jan 26 '12 at 8:13
    
(whoops continued...) Not doubting its the original package. 'root@hoosier:/etc/bind# which named /usr/local/sbin/named' was my response on that. I just don't know where to change the pointer/ init script. apt-get install samba4 worked just fine, but it was around step 6 from [wiki.samba.org/index.php/Samba4/… that told me to get Bind 9.8+ –  Lee Fisher Jan 26 '12 at 8:23
    
@Kamikaze478 Modify the file /etc/init.d/bind9, the /usr/sbin/named path will be in there, and will need to be changed to your newly compiled copy in /usr/local/sbin/. –  Shane Madden Jan 26 '12 at 16:34
    
Thank you. I had about 4 paths listed under #path I just deleted /bin:/sbin:/usr/sbin options altogether. There were 2 command line instances that I needed to modify as well. I was digging myself a hole so deep I was getting "rndc: connect failed: 127.0.0.1#953: connection refused" errors and was starting to "chown root:bind" certain directories. Cause I was unable to restart BIND for about 4 hours. I do get an peculiar message when I restart bind9 though: /etc/init.d/bind9: 130: awk: not found /etc/init.d/bind9: 130: pgrep: not found [ OK ] ...but it works. –  Lee Fisher Jan 26 '12 at 17:25
    
You do not want to remove those directories from your path variable. The cure will be a lot worse than the disease. If anything, mv /usr/sbin/named /usr/sbin/named-9.7. –  Shane Madden Jan 26 '12 at 17:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.