Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got an Access database created with Access 2k3.

When I open the file with Access 2010, I've got error messages, in this order just by clicking OK, Yes, OK :

  1. Error mesage
  2. enter image description here
  3. enter image description here
  4. The VB script editor opens and stops to the first of these lines:

    Private Sub Form_Open(Cancel As Integer)
        DoCmd.Maximize
    End Sub
    

I tried to remove the reference of the missing DLL (Tools/Reference/ and I unchecked the reference marked as "missing"). But when I click to "Save", I've got this error: "The save operation failed"

I also tried to create an empty database and import the old database into this new. But it freezes my window and nothing happens.

I'm not the administrator of my machine and won't be.

I found this log in the log viewer Microsoft Office Alerts

    Microsoft Access
    The Save operation failed.
    P1: 529028
    P2: 14.0.4763.1000
    P3: 
    P4: 

Any idea or feedback to help me?

Thank you in advance!

share|improve this question
    
Removing the reference to the DLL isn't going to remove the code that depends on it. Sounds like you're pretty well stuck with two options: 1. Find the DLL. 2. It's borked. –  Chris S Jan 26 '12 at 13:39
    
It seems that no code depends on that DLL, so the problem seems to be somewhere else –  JiBéDoublevé Jan 26 '12 at 13:46

1 Answer 1

up vote 0 down vote accepted

Try this:

  1. Open Access 2010
  2. Go to File/Options/Current Database and un check all the checkboxes under “Name AutoCorrect Options”
  3. Go to File/New click on blank database set up the name and click on Create
  4. Click on Browse and select the Access 2003 database
  5. Go to External Dta/Access select the option “Import tables, queries, forms, reports, macros, and modules into the current database”
  6. Click OK
  7. Go to each and every tabs of the window and click on “Select all”
  8. Click on OK and wait the import finished
share|improve this answer
    
It took ages to import but it finally did ;) Thank you for the help –  JiBéDoublevé Jan 26 '12 at 14:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.