Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have this problem on at least two separate machines, both of which currently run Ubuntu 8.10. Both machines are desktop machines connected to a LAN by a wired connection. Both networks have static IP addresses assigned to the machines, so I have changed the "Autho eth0" profiles on each to not configure from DHCP, and have provided the IP address, gateway, etc.

However, periodically (sometimes randomly, but mostly whenever I reboot) the network manager has spontaneously created a "new" connection setting for eth0 that boots from DHCP, and when I reboot (or when something causes networking to drop off and re-initialize) the machine ends up with a random address. I dutifully delete the extra entry, and the network manager immediately takes eth0 down and brings it back up, with the correct IP address.

My question is: How do I get the networking manager to cut this crap out? One of the machines is at my office, and if I'm working remotely over our VPN I have no way of (easily) figuring out what the "new" IP address is.

share|improve this question
add comment

4 Answers 4

This is a issue I ran across many times with 8.10 with a server. I had to uninstall Network Manager, after that I had no issues. If you have a static IP you really don't need it anyways. You can either do that or stop it from starting up. I would suggest just uninstalling it all together. I believe it is

sudo apt-get remove gnome-network-manager or sudo apt-get remove network-manager

share|improve this answer
add comment

You can either stop the network manager service (use the services GUI to stop it across reboots too) and remove it from you gnome panel

or you could use network manager to "set up a new connection" I did this when I need to connect over a crossover cable and needed to statically assign IP, DNS, etc. Seemed to work as expected. IIRC I never had any issues with it.

share|improve this answer
add comment

Might it be possible to not use NetworkManager entirely, and just stick with the various ifup/ifdown/ifconfig tools running on startup to establish the connection?

share|improve this answer
add comment

This is what I do on Fedora machines if I am going to use only wired connection. I stop NetWorkManager service. I disable it from startup. I enable network service on startup. I configure network using system-config-network (`neat' on old versions). I disable control of eth0 by NetworkManger. Same can be done through config files in /etc/sysconfig/network-scripts/ifcfg-eth* Just do service network restart and things are fine forever. NetworkManager is useless for wired and only causes problems. Also remove NetworkManager applet from session startup.

The commands on Fedora for above process are:

 service NetworkManager stop
 chkconfig NetworkManager off
 chkconfig network on
 system-config-network &   OR neat &   OR vim /etc/sysconfig/network-scripts/ifcfg-eth* (Put NMcontrolled=NO)
 service network restart
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.