Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have two windows server 2008 servers. One is a web server one is a file server. A php script runs on the web server and is supposed to write to the other server. I am getting a permissions error.

I have given the full UNC path in the php copy command. I also gave IUSR read write permissions and it is still not working.

share|improve this question
    
It depends a bit on how you have PHP set up, but for starters have you looked at the identity of the application pool its running under and tried giving that identity permissions? –  Coding Gorilla Jan 26 '12 at 16:54
    
I set it as my domain account and it still is giving permission errors. –  chronoz Jan 26 '12 at 17:43
    
On the destination server try the user: [SERVER NAME]\NETWORK SERVICE –  Coding Gorilla Jan 26 '12 at 18:31
    
Is the problem only with writing? Have you tested if reading works? (PS. Yes, I know this question is very old.) –  Moshe Katz May 15 at 22:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.