Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is a brand new SuperMicro X9SCL-F with an Intel 82579LM adapter and a fresh install of CentOS 6.2 with cPanel.

I am stuck at 10MBPS, I've tried everything. I've installed the latest 1.95 driver from Intel too, which seems to have fixed this problem for everyone else.

These commands do nothing.

ethtool -s eth1 speed 100 duplex half
ethtool -s eth1 speed 1000 duplex half
ethtool -s eth1 speed 100 duplex full
ethtool -s eth1 speed 1000 duplex full

They result with this in dmesg:

[ 1081.662365] e1000e 0000:02:00.0: eth1: Reset adapter
[ 1084.298376] e1000e: eth1 NIC Link is Up 10 Mbps Half Duplex, Flow Control: None
[ 1084.298443] e1000e 0000:02:00.0: eth1: Autonegotiated half duplex but link partner cannot autoneg. Try forcing full duplex if link gets many collisions.
[ 1084.298446] e1000e 0000:02:00.0: eth1: 10/100 speed: disabling TSO

This command knocks me off the network

ethtool -s eth1 speed ... autoneg off

Outputs

ethtool eth1

Settings for eth1:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full 
100baseT/Half 100baseT/Full 
1000baseT/Full 
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full 
100baseT/Half 100baseT/Full 
1000baseT/Full 
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Speed: 10Mb/s
Duplex: Half
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
MDI-X: off
Supports Wake-on: pumbag
Wake-on: g
Current message level: 0x00000001 (1)
Link detected: yes

ethtool -i eth1

driver: e1000e
version: 1.9.5-NAPI
firmware-version: 2.1-2
bus-info: 0000:02:00.0

Full dmesg:

[    2.332156] e1000e: Intel(R) PRO/1000 Network Driver - 1.2.20-k2
[    2.332159] e1000e: Copyright (c) 1999 - 2010 Intel Corporation.
[    2.332209] e1000e 0000:00:19.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
[    2.332225] e1000e 0000:00:19.0: setting latency timer to 64
[    2.332508] e1000e 0000:00:19.0: irq 31 for MSI/MSI-X
[    2.573664] e1000e 0000:00:19.0: eth0: (PCI Express:2.5GB/s:Width x1) 00:25:90:57:38:e5
[    2.573668] e1000e 0000:00:19.0: eth0: Intel(R) PRO/1000 Network Connection
[    2.573718] e1000e 0000:00:19.0: eth0: MAC: 10, PHY: 11, PBA No: FFFFFF-0FF
[    2.573777] e1000e 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[    2.573802] e1000e 0000:02:00.0: setting latency timer to 64
[    2.574078] e1000e 0000:02:00.0: irq 32 for MSI/MSI-X
[    2.574083] e1000e 0000:02:00.0: irq 33 for MSI/MSI-X
[    2.574088] e1000e 0000:02:00.0: irq 34 for MSI/MSI-X
[    2.574297] e1000e 0000:02:00.0: Disabling ASPM L0s 
[    2.657292] e1000e 0000:02:00.0: eth1: (PCI Express:2.5GB/s:Width x1) 00:25:90:57:38:e4
[    2.657296] e1000e 0000:02:00.0: eth1: Intel(R) PRO/1000 Network Connection
[    2.657380] e1000e 0000:02:00.0: eth1: MAC: 3, PHY: 8, PBA No: FFFFFF-0FF
[   14.181499] e1000e: eth1 NIC Link is Up 10 Mbps Half Duplex, Flow Control: None
[   14.181565] e1000e 0000:02:00.0: eth1: Autonegotiated half duplex but link partner cannot autoneg.  Try forcing full duplex if link gets many collisions.
[   14.181567] e1000e 0000:02:00.0: eth1: 10/100 speed: disabling TSO
[  476.773721] e1000e 0000:02:00.0: PCI INT A disabled
[  476.789823] e1000e 0000:00:19.0: PCI INT A disabled
[  476.935605] e1000e: Intel(R) PRO/1000 Network Driver - 1.9.5-NAPI
[  476.935608] e1000e: Copyright(c) 1999 - 2011 Intel Corporation.
[  476.935639] e1000e 0000:00:19.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
[  476.935651] e1000e 0000:00:19.0: setting latency timer to 64
[  477.008135] e1000e 0000:00:19.0: irq 31 for MSI/MSI-X
[  477.184223] e1000e 0000:00:19.0: eth0: (PCI Express:2.5GT/s:Width x1) 00:25:90:57:38:e5
[  477.184227] e1000e 0000:00:19.0: eth0: Intel(R) PRO/1000 Network Connection
[  477.184298] e1000e 0000:00:19.0: eth0: MAC: 11, PHY: 11, PBA No: FFFFFF-0FF
[  477.184309] e1000e 0000:02:00.0: Disabling ASPM L0s 
[  477.184393] e1000e 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[  477.184417] e1000e 0000:02:00.0: setting latency timer to 64
[  477.184836] e1000e 0000:02:00.0: irq 32 for MSI/MSI-X
[  477.184839] e1000e 0000:02:00.0: irq 33 for MSI/MSI-X
[  477.184841] e1000e 0000:02:00.0: irq 34 for MSI/MSI-X
[  477.334438] e1000e 0000:00:19.0: irq 31 for MSI/MSI-X
[  477.385281] e1000e 0000:00:19.0: irq 31 for MSI/MSI-X
[  477.386305] e1000e 0000:02:00.0: eth1: (PCI Express:2.5GT/s:Width x1) 00:25:90:57:38:e4
[  477.386308] e1000e 0000:02:00.0: eth1: Intel(R) PRO/1000 Network Connection
[  477.386458] e1000e 0000:02:00.0: eth1: MAC: 4, PHY: 8, PBA No: FFFFFF-0FF

Card is one of the following (not sure which):

00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 05)
    Subsystem: Super Micro Computer Inc Device 1502
    Flags: bus master, fast devsel, latency 0, IRQ 31
    Memory at fba00000 (32-bit, non-prefetchable) [size=128K]
    Memory at fba24000 (32-bit, non-prefetchable) [size=4K]
    I/O ports at f020 [size=32]
    Capabilities: [c8] Power Management version 2
    Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [e0] PCI Advanced Features
    Kernel driver in use: e1000e
    Kernel modules: e1000e

02:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection
    Subsystem: Super Micro Computer Inc Device 0000
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at fb900000 (32-bit, non-prefetchable) [size=128K]
    I/O ports at e000 [size=32]
    Memory at fb920000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: [c8] Power Management version 2
    Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [e0] Express Endpoint, MSI 00
    Capabilities: [a0] MSI-X: Enable+ Count=5 Masked-
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [140] Device Serial Number 00-25-90-ff-ff-57-38-e4
    Kernel driver in use: e1000e
    Kernel modules: e1000e
share|improve this question
2  
And are you connected to a device that supports more then 10mb, and isn't configured to limit your speed to 10mb? –  Zoredache Jan 26 '12 at 22:01
1  
Yep, that was it. I could have sworn it was burstable though. Seems others have had similar problems with these adapters so it never even occurred to me. Yes, I feel very stupid right now. –  Sam Jan 26 '12 at 22:27
    
I think you mean 10 Mbps. –  MDMarra Jan 27 '12 at 1:04
1  
@Sam: Since the issue is resolved, can you please come back and accept Zoredache's answer? –  pauska Jan 27 '12 at 1:11
1  
@pauska - Done! –  Sam Jan 29 '12 at 12:53
add comment

3 Answers

up vote 3 down vote accepted

Since it seems like you have already spent a fair amount of time verifying that your equipment is working, it might be time to step back and perform a one of those really basic, should have been obvious checks.

Double check that the switch/hub/device you are connected too, actually supports a link speed greater then 10mb, and that it doesn't have any configuration limiting it to 10mb only.

share|improve this answer
    
Yep, that was it. I'm in 3 other facilities on <= 10mbps plans but they're all burstable, this is my first server in this new facility and it never even occurred to me. This ethernet adapter is giving me other kinds of trouble too, so I never even thought beyond it. Thanks! –  Sam Jan 29 '12 at 12:57
add comment

I see you mentioned autonegotiation, but if you turn off autonegotiation you need to do it at both sides (on the server side as well as the switch side.) Generally, if a card is having trouble autonegotiating it could be due to interference from outside sources. As Squidly says, you may have a bad cable. So, my suggestion to you would be, in this order:

  1. Try setting autonegotiation off on both sides, manually bringing both sides of the link up to 1000/Full.
  2. Failing that, try replacing the cable with a new or known-good cable.
  3. It is entirely possible you just have a bad NIC, it's been known to happen.
share|improve this answer
add comment

This has happened to me in the past. It Have you tried Different ports on the switch and a different Ethernet Cable. I've seen where a bad cable will give you link but not show you have a good enough connection to the pins to keep the signal of proper quality for higher then 10/Half.

share|improve this answer
    
+1 - I've had multiple situations where it turned out that bad cabling was the cause of exactly this problem. Gigabit Ethernet on copper is very intolerant of sub-par cabling. –  Evan Anderson Jan 26 '12 at 22:09
1  
Yes, I just finally considered it could be a hardware issue so I called the DC to see if they could switch the cable and try my second port. That's when they told me my 10mbps off the switch wasn't burstable. I'm an idiot. Thanks for your help guys. –  Sam Jan 26 '12 at 22:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.