Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Here is my initial setup.

I have a router, a switch is connect to that router, on that switch is a Physical Server, on that server is a virtual machine (WIN2K8R2 192.168.1.21) and also on that switch is a physical workstation (WORKDESKTOP 192.168.1.100).

Physical Server is using EXSI Hypervisor 5.0, Virtual Machine is Windows Server 2008 R2, Phyiscal Workstation is Windows Pro 7 64bit

Now I have setup DHCP, DNS, AD on the WIN2K8R2 server, and have successfully connect the WORKDESKTOP to this server. So the LAN part is working fine.

The server can also access the internet.

Howver the workstation cannot access the internet for some reason.

The workstation does not show a gateway, manually setting the gateway through to my server ip (192.168.1.21) must trick it into thinking there is internet as it says there is but I cannot ping anything.

As far as I know the routing tables on the server look correct because it shows when using the route print command: 192.168.1.0 blah blah 192.168.1.21 which should be correct, I think.

Am I overlooking something?

How do I continue my troubleshooting?

share|improve this question
    
Please post your routes and ipconfig information for your workstation, server and router. –  kce Jan 26 '12 at 22:09
add comment

2 Answers

up vote 4 down vote accepted

The workstation does not show a gateway, manually setting the gateway through to my server ip (192.168.1.21) must trick it into thinking there is internet as it says there is but I cannot ping anything.

Your workstation can route fine to your server because they're on the same subnet. Your workstation needs to know the route out - this is presumably your router (which is different from your Windows 2008 R2 server, correct?). Unless you have specifically configured your server to route for your 192.168.1.0/XX network, telling your workstation that it is the default gateway will not accomplish what you want.

What is the default gateway set to for your server? Set your workstation to use that as the default gateway instead of your server (192.168.1.21). If you specifically want your server to do the routing then you need to establish the appropriate static routes on you server (and possibly a whole mess of other things depending on how your outbound connection is setup).

share|improve this answer
    
My default gateway for my server is my router, which is 192.168.1.1 so when i set this as the gateway for my workstation the internet works. How would I go about doing this in the DHCP role of the server to make it automatically set the gateway of any client that connects to 192.168.1.1? Also is there any point in having DNS on my server anymore? –  Mike Hagstrom Jan 27 '12 at 2:23
    
You need to set your DHCP server's scope options accordingly. Active Directory and DNS are tightly integrated. You can't have AD without DNS –  kce Jan 27 '12 at 18:20
add comment

The DG on the workstation should point to the router not the server, unless the server is acting as the DG, which it doesn't sound like it is.

In your DHCP configuration, you'll want to set Scope or Server options to provide the DHCP clients with:

  1. Router

  2. DNS Server(s)

  3. DNS Domain Name (optional)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.