Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This feels like a dumb question, but here goes.

I have a Cisco Catalyst 2960S switch that is currently running software version 12.2(55)SE3

The most current software listed on Cisco's website is 12.2.58-SE2(ED) and 15.0.1-SE2(ED)

Do I need to remain on the 12.x series of software, or can I use the 15.x software?

share|improve this question
add comment

3 Answers 3

up vote 4 down vote accepted

Stick with 12.2(55)!

IOS 12.2(58) and higher have major memory leak issues that can lock you out of the switch (console included) and should be used with caution. Details. This bit me in the you know what pretty hard. Although to answer your question - technically yes you could upgrade to 15 if you wanted to.

share|improve this answer
    
+1. Bug details here: tools.cisco.com/Support/BugToolKit/search/… (CCO required) –  petrus Jan 27 '12 at 19:46
add comment

For the least amount of upgrade surprise, I would go to 12.2(largest number possible) SE(largest number possible).

You can go to 15.0.1.whatever, but that would entail more lab/staged roll-out testing.

If you have just one switch, then unless you are actually suffering outages due to software bugs, I would not recommend an upgrade. If you need new features, doing it on one switch only is a bad plan.

share|improve this answer
add comment

That will depend on what you are doing with the switch.

The 12.2 series is VERY mature and stable. If your switching is fairly static and you have no need for new features, then stick with the latest 12.X. You could probably upgrade it now and never touch it again unless there is a security flaw you need to plug.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.