Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running an Ubuntu Server, I already have silent enabled in Grub2, so the kernel doesn't show any output.

In addition, I now I want to hide the runlevel/services output. Is that possible?

I don't even mind changing some code in the services system to do this. In other words, the solution doesn't have to be graceful, I just want it to work!

share|improve this question
add comment

1 Answer

To disable console output during kernel bootup, use the quiet option on the kernel command line.

The easiest way to achieve this in case if grub is silent:

Edit /etc/default/grub file by adding the kernel parameter:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Then execute following:

sudo update-grub

UPDATE:

In case if you want disable usplash graphical splash screen:

Edit /usr/share/initramfs-tools/conf-hooks.d/usplash file by adding following:

USPLASH=n

Then execute following:

sudo update-initramfs -u
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.