Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been getting an error in cron like this:

CRON[17744]: (CRON) error (grandchild #17745 failed with exit status 1)

in syslogs. I ignored it for a while (brilliant, I know), and then suddenly my vps had exceeded its inode quota. Poking around, it turns out that php wasn't deleting session files, which I assume is the cron error I am seeing (some hints at this here). Here's my /etc/cron.d/php5 entry:

09,39 *     * * *     root   [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -depth -mindepth 1 -maxdepth 1 -type f -cmin +$(/usr/lib/php5/maxlifetime) ! -execdir fuser -s {} 2>/dev/null \; -delete

I assume the cron entry is okay, since I can't believe I've edited it... what could be wrong with my setup?

share|improve this question
up vote 2 down vote accepted

I ran into this the other day on Ubuntu 11.10. There's an open bug - and restoring 11.04's /etc/cron.d/php5 command worked perfectly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.