Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I configured an FTP server for Ubuntu using vsftpd. However, I can't access the server.

Status: Connecting to IP
Status: Connection established, waiting for welcome message...
Response:   220 (vsFTPd 2.3.2)
Command:    USER userhere
Response:   331 Please specify the password.
Command:    PASS ***************
Response:   500 OOPS: could not read chroot() list file:/etc/vsftpd.chroot_list
Error:  Critical error
Error:  Could not connect to server

EDIT

The problem was solved ! Comment the line chroot_list_enable=YES

share|improve this question
    
I'd say this is more like disabling the feature, it's not fixing the problem. But it doesn't matter if your FTP server now do what you want it to :-) About the answer, instead of editing your main post, mark the answer you used as being the answer :) –  Frands Hansen Jan 29 '12 at 9:42
add comment

2 Answers

Quick fix would be to disable chroot_list_enable switch in your conf file for Vsftpd( usually in /etc/vsftpd.conf)

#chroot_list_enable=YES
#chroot_list_file=/etc/vsftpd.chroot_list

Comment out mentioned line above and see it helps or not.

share|improve this answer
add comment

you must apply below command,

setsebool -P ftp_home_dir on

setsebool -P allow_ftpd_full_access=1

I solved this method.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.