Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Firefox:

"You have chosen to open (no file name here?) which is a: application/x-httpd-php (12.6 KB) from http://localhost"

"What should Firefox do with this file? Open with () Save File [ BROWSE ]"

And if I Save File, the file names is: "ywooukMV.part" ???

Chrome:

Just prompts for download of file name. And the file name by default is "download"


I spent some time researching this, and all I could locate as a "fix" was to ensure my httpd.conf had the correct call for:

AddType application/x-httpd-php .php

In addition, I am having no problem reading other php files. This is the only directory (in any directory below it as well) that prompts this download and will not load the file.

I am using WAMP server. I've tried multiple versions of Apache and PHP and the result is the same.

I have other php files and directories in the same localhost, and none of them have this same problem.

There is no .htaccess file located in the directory either which I thought might be something that could cause this with a configuration.

Is there something specific I can look for to resolve this?

I'm at a dead end.

share|improve this question

closed as not a real question by Iain Jan 29 '12 at 8:40

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Ok. I lost enough hair over this. My IDE ftp explorer and file tree where not showing the .htaccess file. But I re-checked in explorer and found that was the culprit. SOLVED.. –  OldWest Jan 29 '12 at 2:58
add comment