Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Mac OS X Snow Leopard cannot bind to my Active Directory (Tiger, Lion can with no problem). I go to Accounts > Login Options, click Join and enter the details. Upon entering the correct FQDN ( I get an Active Directory Settings dropdown, into which I enter the correct admin credentials.

I then get an error dropdown which says:

The plugin encountered an error processing request. (10001)

In the Console I have the error:

System Preferences[55582] -[ODCAddServerSheetController handleOtherActionError: gotError: Error Code=4200 UserInfo=0x2003db6e0 "Custom call 202 to LDAPv3 failed.", An invalid attribute type was provided.

The output of dig -t is:

; <<>> DiG 9.6-ESV-R4-P3 <<>> -t SRV
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 27437
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; IN    SRV

;; ANSWER SECTION: 600 IN SRV 0 100 389


;; Query time: 9 msec
;; WHEN: Tue Jan 31 14:18:33 2012
;; MSG SIZE  rcvd: 101

I have tried this on two Snow Leopard machines connected to the same network, I get the exact same results with both of them.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

There were old settings that needed manual removal:

$ cd /Library/Preferences
$ mv

Once this was done I was able to bind successfully.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.