Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Our workstations (Windows 7 machines) connect to users' home folders on the domain's File Server (Windows Server 2008 standard), using a UNC path like \\server\users$\...

This has worked fine for a long time. Now all of a sudden several computers, but not all, can't access it. It says the user doesn't have permission. Using a path with a fully qualified domain name like \\server.domain.org\users$ DOES work, as does with the IP such as \\10.7.1.2\users$.

Nothing would have changed on the workstation's end, but wiping it clean by re-imaging fixes the problem. I'm not convinced the problem is on the workstation's end. I've tried everything obvious like disabling the Windows Firewall, rejoining the domain, removing antivirus, and also tried some registry tweaks I've seen suggested online.

share|improve this question
    
I have seen network settings (not on the client but actual network equipment/settings) require you to use the FQDN UNC vs the shorter path. I haven't seen it go in and out like that though, especially tied in with the remimaging of a workstation. –  Chadddada Jan 31 '12 at 17:51
    
I haven't been able to figure it out, so I just changed all the AD Profile paths to use the FQDN. Today a laptop came in with the same problem, except it wasn't working with the FQDN, but did with just the server name! –  Adam Feb 6 '12 at 16:22

1 Answer 1

up vote 1 down vote accepted

It turns out the problem was corrupted offline files cache. So accessing the share with a different path uses a different offline files cache, one that's not corrupted.

Re-initializing the cache with the instructions found here (http://support.microsoft.com/kb/230738) fixed the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.