Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently I ran into a very strange phenomenon with one of the servers I manage used to serve samba shares over the local network. It was running Ubuntu Server 8.04 and I decided to upgrade the distribution. After painstakingly pushing one release at a time I ended up with version 10.04. The server threw an error with mounting one of the drives (sdb1) so I edited the fstab so it used the drive's UUID instead of an absolute path. After remounting everything the original contents of /dev/sdd1 were missing and were replaced by files that we thought we lost 2 years ago.

Here is the list of drives on the system (sda2 is logical containing sda5 which is swap)

ls /dev/sd*
/dev/sda   /dev/sda2  /dev/sdb   /dev/sdc   /dev/sdd
/dev/sda1  /dev/sda5  /dev/sdb1  /dev/sdc1  /dev/sdd1

df /dev/sd*1 -H
Filesystem             Size   Used  Avail Use% Mounted on
/dev/sda1              487G   459G   2.9G 100% /
/dev/sdb1              493G   433G    35G  93% /srvnew
/dev/sdc1              501G    28G   448G   6% /srvb
/dev/sdd1              1.5T   112G   1.3T   8% /srv15

As you can see there are four hard drives in the system and are all mounted. There is no logical reason why the data of sdd1 should be swapped. Because I am working remotely over SSH, I made the guys that own the server to physically open its case and confirm there are four hard drives installed :)

Another strange thing is that they reported the fourth hard drive was also 500GB and not 1.5TB and nobody swapped drives.

Tried running data recovery on each drive which returned no files (expected as no files are ever deleted from the server). I am really confused and have no idea where to start from.

share|improve this question
You can directly upgrade from LTS to LTS; you didn't need to do all of the upgrades in between. – psusi Jan 31 '12 at 19:05
8.04's support has been dropped and repositories are moved to and which makes editing paths in system files labor intensive. Also in the official Ubuntu documentation, this is shown as the way to go. – Alexander Ivanov Feb 1 '12 at 8:12
You can start with the output of gdisk -l against each of /dev/sd[abcd]. – JdeBP Feb 1 '12 at 11:25
You only needed to muck with old-releases to get the intermediate releases that are no longer supported. You wouldn't have needed that to upgrade straight to 10.04, which is still supported. See – psusi Feb 1 '12 at 15:17
up vote 3 down vote accepted

Sounds to me like you had files in the directory that is the mount point for your sdd1 disk.

This happened to my technician a few times. Mounting a disk on a location masks what's already in it. When it's unmounted, the old files are visible again.

share|improve this answer
I totally missed that one - thanks a lot! – Alexander Ivanov Feb 1 '12 at 11:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.