Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

NEED HELP!!! I installed apache2, svn and redmine on an ubuntu server. After that I tried to do my authentication for svn over the redmine accounts. My apache config looks like this (stored in /etc/apache2/conf.d/svn.config):

 PerlLoadModule Apache::Redmine
 <Location /svn>
   DAV svn
   SVNParentPath "/var/svn" 
   Order deny,allow
   Deny from all
   Satisfy any

   PerlAccessHandler Apache::Authn::Redmine::access_handler
   PerlAuthenHandler Apache::Authn::Redmine::authen_handler
   AuthType Basic
   AuthName "Redmine SVN Repository" 

   #read-only access    
     Require valid-user
     Allow from
     # Allow from another-ip
     Satisfy any
   # write access
     Require valid-user

   ## for mysql
   RedmineDSN "DBI:mysql:database=redmine;host=localhost" 

   RedmineDbUser "redmine" 
   RedmineDbPass "mypass" 

The problem: I see the login window when i try to connect over http but after confirming nothing happens and an other login window opens. Also with the TortoiseSVN client. I can reach the server but the login doesn't work. I think it is a problem between apache, the and mysql or a missconfiguration.

Can someone help me?


I use the for this. I copied it to the /usr/lib/perl5/Apache/ folder. The Mods "dav", "dav_svn" and "perl" for apache are also enabled but the problem persists. Redmine users are stored in a mysql database.

The apache2 error-log looks like this:

[Fri Feb 03 23:00:26 2012] [notice] caught SIGTERM, shutting down
[Fri Feb 03 23:00:28 2012] [notice] Apache/2.2.20 (Ubuntu) DAV/2 SVN/1.6.12 Phusion_Passenger/2.2.11 mod_perl/2.0.5 Perl/v5.12.4 configured -- resuming normal operations

The apache2ctl -S returns this:

ulimit: 88: error setting limit (Operation not permitted)
apache2: Could not reliably determine the server's fully qualified domain name, using for ServerName
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:80                   is a NameVirtualHost
     default server (/etc/apache2/sites-enabled/000-default:1)
     port 80 namevhost (/etc/apache2/sites-enabled/000-default:1)
Syntax OK

When I try to connect to the repo with svn ls http://localhost/svn/repo I get this:

Could not authenticate to server: rejected Basic challenge (http://localhost)
share|improve this question

1 Answer 1

up vote 3 down vote accepted

I asked a friend for this and the fault was really simple. I don't set the permissions for access the repository to the used user. In Redmine you can add groups and users and you can set the group of an user for each project so I need to add my user to the project with an group that is able to access the repository.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.