Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The SCSI bus designated "c6" is stuck in an unconfigured state, and I cannot get the server to recognize the tape drive attached to this bus because the bus itself is not configured. Here's an example of what's happening:

# cfgadm -c configure c6
# cfgadm -al
Ap_Id                          Type         Receptacle   Occupant     Condition
c0                             scsi-bus     connected    configured   unknown
c0::dsk/c0t6d0                 CD-ROM       connected    configured   unknown
c1                             fc-private   connected    configured   unknown
c1::21000014c3cb097f           disk         connected    configured   unknown
c1::21000014c3cb09ca           disk         connected    configured   unknown
c2                             scsi-bus     connected    unconfigured unknown
c3                             fc-private   connected    configured   unknown
c3::202400a0b83aa034           disk         connected    configured   unknown
c6                             scsi-bus     connected    unconfigured unknown
c7                             scsi-bus     connected    unconfigured unknown
usb0/1                         unknown      empty        unconfigured ok
usb0/2                         unknown      empty        unconfigured ok
usb0/3                         unknown      empty        unconfigured ok
usb0/4                         unknown      empty        unconfigured ok

Note that c6 is still unconfigured. I have tried reboot -- -r and devfsadm but neither of these worked. I also tried using the -f option with the cfgadm configure command, but this also did not help.

Any ideas would be greatly appreciated!

share|improve this question
    
Have you verified that the tape drive actually works (e.g. attached to another machine)? –  James O'Gorman Jan 31 '12 at 18:55
1  
The problem turned out to be the terminator on the drive connected to the bus. At first, probe-scsi-all did not recognize the SCSI controller or the tape drive, but after I removed the terminator, it recognized everything correctly. I did a boot -r for good measure, and now the SCSI controller and tape drive both show up in Solaris. I still can't get it to read the tape, but that's not a problem for this thread. –  Dave Jan 31 '12 at 19:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.