Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When I am trying to access WMI from a remote domain controller using WMIMGMT.MSC, I keep getting "Failed to connect to \(remote server) because 'Win32: Access is denied.'. Does anyone have any ideas on what could be causing this?

I have tried many of the different howtos I found through google and none of them worked. I renamed the logs and repository folder under C:\system32\wbem and rebuilt the repository. After this didn't work, I went into the security tab under WMI Control and allowed 'Everyone' all rights. This did not fix the problem. I believe it has something to do with impersonation, but when I tried a few google searches for this, it brought up scripting and programming help.

I can access WMI locally on the remote computer with no issues

share|improve this question
    
Something else to add. I can access WMI locally on the remote computer with no issues. –  Jacob Jan 31 '12 at 19:04
    
When you write "remote domain controller", are you talking about a domain controller in the same domain, or in a "remote" domain (one that doesn't trust your domain) –  Mathias R. Jessen Jan 31 '12 at 20:04
    
It belongs to the same domain. –  Jacob Jan 31 '12 at 20:48

1 Answer 1

It sounds like a firewall issue. You can run netsh firewall set service RemoteAdmin enable to create the firewall exception for remote WMI access.

If the account that you're using is not an administrator on the target machine, you'll also need to configure some DCOM settings on the target machine, as outlined here.

share|improve this answer
    
If it was a DCOM issue, wouldn't it prevent me from viewing the event viewer and services remotely? I am able to remotely view the event viewer and services. Also, I do not have windows firewall enabled on the machine. –  Jacob Jan 31 '12 at 21:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.