Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We are in the process of rolling Office 2010 via SCCM 2007 to about 500 machines in our department. Everything is going swimmingly except... suggested contacts. I am looking for a way to remotely disable Suggested Contacts.

None of our test subjects for this deployment use the contacts feature on their IOS devices(iPhones and iPads), something that has turned out to be a major oversight on our part. If you are unfamiliar with Suggested Contacts - every time you send an email to someone who is not currently a contact Outlook saves that email address in an Address book called 'Suggested Contacts'. If you have an iOS device these contacts automatically sync to the device causing hundreds if not thousand extra(and duplicate) contacts.

I've found how to manually disable this per user here. but manually disabling this is not really an option for the several hundred users we have that use iOS devices. I've looked for a GPO setting, a command line switch or a setting that can be set during the install(set through the MS Office Customization Tool) with no luck. There is, in theory, a registry key(as seen here for example) that should disable the setting but Outlook overwrites this setting each time you restart Outlook. You can make this setting read only for standard users but that seems to cause angry messages from Outlook.

I see other people looking for a way to handle this but I don't see any solutions. Any suggestions?

share|improve this question

1 Answer 1

I don't know know how old this is but I think I might have found a GPO that may help. Credit where credit is due, here is the link that pointed me to it: http://adrianchatto.wordpress.com/2012/05/30/disableenable-auto-suggest-contacts-in-outlook-2010-and-2007-with-gpo/

First you need to download the Administrative templates for Office2010. I downloaded them and extracted them to my desktop. Then I took the outlk14.admx file and copied it to my domain controllers C:\Windows\PolicyDefinitions\ folder. You must also copy the outlk14.adml file to C:\windows\PolicyDefinitions\en-US\ otherwise you get a parsing error when you open the GPME and click on the Administrative Templates. So then I created a GPO called Outlookfix and an OU in my domain to link the GPO to. Edit the GPO and with the files in place you should be able to navigate to the following: User Configuration\Policies\Administrative Templates\Microsoft Outlook 2010\Outlook Options\ Preferences\Email Options\Advanced E-mail Options\When sending a message

I set the "when sending a message" to enabled and checked everything EXCEPT "Automatic name checking" and "Suggest names while completing To, Cc, and Bcc fields"

I then moved a test computer into the OU I created on the domain and ran gpupdate /force. Open outlook, new message, and when I type in an email address that previously was a suggested contact it doesn't auto complete. One thing to note this doesn't deleted the current suggested contacts it just disables using them on "sending a message" which ultimately was the behavior I needed.for my problem.

I hope this give some other people some ideas because this has be something that has plagued me since upgrading to Exchange2010 / Outlook 2010.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.