Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Networking newb here... I seem to be having an odd networking issue.

When I am using a PC/laptop/Smart phone on my local network I am unable to access web pages (or email) on my network server using the FQDN.

Here's the set-up:

  • Domain name provider that points to the static IP address e.g. example.com points to 222.111.111.001
  • Fixed IP router address: e.g. 222.111.111.001
  • dd-wrt router: 192.168.1.1 It has port-forwarding to the Ubuntu server which seems to work as it serves pages, etc to non-local ip addresses. Local machines are issued ip address via DHCP in the 192.168.1.100 to 149 range.
  • Ubuntu 10.04 server on 192.168.1.150
  • Clients include Linux mint machines, Android phone and get addresses such as 192.168.1.104

If I am on a client on the local network ( 192.168.1.104) and I try to navigate to a webpage on example.com/index.htm then the request times out. The same sort of thing applies to email - If I am connected on the local network (wirelessly) then I cannot access the IMAP and SMTP servers using mail.example.com

The situation is fine if I am using a non-local network (e.g. my Vodafone mobile network). The device will successfully load example.com/index.htm The situation is also ok if I navigate to 192.168.1.150/index.htm

Any thoughts on how to trouble shoot this one? It's obviously a little annoying...

Cheers.

share|improve this question

3 Answers 3

I see you are using DD-WRT. That's unfortunate. I (and others here) have found it to be notoriously unreliable.

Insure that DNS is working. From your local network client (192.168.1.104) do a DNS lookup on your domain example.com and make sure the correct 222.111.111.001 address is returned. This will verify that DNS is functioning appropriately for your local clients.

Then see if you can access your server from a local client using its "external" IP address (i.e., 222.111.111.001). If you cannot access your server this way, then I suspect your router is the problem. If you can access your server, I suspect DNS or possibly a bad virtual hosting configuration (you mentioned a webserver) could be at fault.

  • Make sure you are using an "approved" build of DD-WRT. Upgrade (or downgrade) to one of the forum recommended builds listed in this section, especially if you are running SP1 or v24 final (05/21/08 )13064 or 14896. Read this forum thread. Make sure you don't just blindly flash your router with firmware - you'll have to troll through forums to find out which version of DD-WRT works best with your particular router, version and revision.
  • Provided your DNS is functioning correctly, this could be caused by a bug in DD-WRT that breaks NAT Loopback.
share|improve this answer

Have you tried running something like a nslookup to see what your FQDN resolves to from inside your network?

In addition to the DNS issue possibility, you may only have your port-forwarding set up for connections originating outside of your LAN. It could also be many other things, hard to say with limited information.

share|improve this answer

I think you're misunderstanding how DNS lookups work.

The public domain name that your URL is pointing to is a data record that is offered to the public. It doesn't have anything to do with the DNS service available on your local network.

Check your DD-WRT to make sure that you have a DNS server configured. Try using Google's at 8.8.8.8 and 8.8.4.4 for testing that.

If you don't have a DNS server configured in your DHCP service, your devices can't resolve FQDNs on the devices that have received IPs from the router.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.