Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In Windows Vista, is there a way to remove the word 'Administrator:' from the title of a command prompt window?

The 'title' command just updates the part after 'Administrator:', so that will not do.

share

locked by Tom O'Connor Oct 21 '13 at 15:21

This post has been locked due to the high amount of off-topic comments generated. For extended discussions, please use chat.

comments disabled on deleted / locked posts

7 Answers

up vote 11 down vote accepted

There are another two possibilities here:

  • Use the cmd.exe from Windows XP
  • Modify the MUI data for cmd.exe:

You’ll need to modify the MUI data file for cmd.exe. This file is called cmd.exe.mui, and is located in C:\Windows\System32\en-US on a standard 32-bit, United States installation. For other languages, the en-US will be different, and for 64-bit installations, you’ll need to modify both the version in System32 and in SysWOW64.

  • First off, take ownership of cmd.exe.mui. Right-click on the file, click Advanced on the security tab. On the Owner tab, click Edit, and select the Administrators account.

  • Now, give access to modify the file. Go back into the properties for the file, click Edit on the Security tab, click Add, and enter Administrators, then make sure they have the Full Control option set to Allow.

  • Using a hex editor, resource editor, or other editor of your choice, modify the string in the file from “Administrator: %0” to “ %0” (That’s two spaces before the %0, don’t forget the null character at the end).

  • Save the file

  • Run mcbuilder.exe (this could take some time to run)

  • Reboot the computer.

(from this thread - note, you can use a space, but it has to be something.)

share
    
Someone should write a tool to do this.... –  Unkwntech Jul 3 '09 at 15:26
    
I choose the easy way and took a cmd.exe from XP. Thanks a lot! –  eli Jul 3 '09 at 20:28
    
It seems to work with only a single space before "%0", too. I didn't try to remove the last space, but I wouldn't be surprised if that's possible. –  torhu Jan 9 '12 at 16:21
    
On Windows 8 x64 I didn't have to run mcbuilder.exe. I found cmd.exe.mui in one of the SxS folders. Every string in there was UTF-16, so keep that in mind and remember the null bytes in your search. –  Plynx Dec 30 '12 at 10:06
    
This is an excellent answer, but it's effing annoying to have to do this. –  Camilo Martin Aug 20 '13 at 21:38
show 1 more comment

While it has been proven not to solve the problem in this bug, not everyone knows you can use the title command and set the title to whatever you want it to be.

share
    
Woot! Didn't know about the "title" command. Thanks. –  Wesley Jul 3 '09 at 14:19
3  
Unfortunately, it does not remove the 'Administrator:' part. I updated the question. –  eli Jul 3 '09 at 14:22
    
You don't need to down-vote useful distractions. The correct answer will be marked accepted, but there is other useful stuff to be gleamed by other answers, you know... –  crb Jul 3 '09 at 15:28
    
sorry man, somebody else voted you down. but I appreciate your effort, so I'll vote you up ;-) –  eli Jul 3 '09 at 20:16
add comment
runas /trustlevel:0x20000 "cmd /k title My Awesome Command Prompt"
share
    
This will just run it as non-admin, right? –  Camilo Martin Aug 29 '13 at 3:13
add comment

Run the command prompt as a standard user (ie be logged in as a standard user).

If needed, you can always use runas to run commands as any other user including whatever adminstrative users you have.

share
add comment

Why do you want to remove it? It's there to signify that you're running an elevated command prompt as opposed to a regular command prompt.

If you've disabled the UAC then you might see this on all your command prompts as you're basically always running in elevated mode

share
7  
Because I use the title command to identify the different command prompts in my task bar, and there is not enough room in the taskbar button. –  eli Jul 3 '09 at 14:26
add comment

I haven't tried this, but what about creating an Administrator account called "a", and then changing your CMD shortcut to be a "runas," calling CMD with "a" as the user.

That will shorten up the name so you can fit the real title nicely in the taskbar (which you indicated was your goal for doing this).

share
1  
It will still show Administrator: as far as I can tell because what it tries to show is that the prompt is elevated - not which user is running it. –  Oskar Duveborn Jul 3 '09 at 16:20
add comment

I stopped using the standard cmd.exe shell, and am now using Console2 which does not have this 'administrator' problem.

share
    
That's not actually true: it has the exact same problem. Apparently it's just some kind of shallow wrapper around the built in command window and uses the title that cmd provides to it. –  sh1ftst0rm Oct 8 '13 at 16:58
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.