Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

hi i tried to install google speed mod on my (MT) DV server and i got this error while trying to restart the httpd can anyone help

Syntax error on line 210 of /etc/httpd/conf/httpd.conf: Syntax error on line 1 of /etc/httpd/conf.d/pagespeed.conf: Cannot load /usr/lib/httpd/modules/mod_pagespeed.so into server: /usr/lib/httpd/modules/mod_pagespeed.so: wrong ELF class: ELFCLASS32

I followed this TUT http://wiki.mediatemple.net/w/(dv):Install_mod_pagespeed#Instructions to part 9 where you do phpinfo... did i need to do more im not sure

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

It looks like you installed a 32bit binary on a 64bit server.

You can verify yoru architechure by issuing the uname -a command. It will show something similar to:

Linux localhost.localdomain 2.6.32-220.2.1.el6.x86_64 #1 SMP Fri Dec 23 02:21:33 CST 2011 x86_64 x86_64 x86_64 GNU/Linux

The important part is the x86_64 bit. What you want to do now is:

#rpm -e `rpm -qa | grep pagespeed`
#rpm -i https://dl-ssl.google.com/dl/linux/direct/mod-pagespeed-beta_current_x86_64.rpm

Everything should work then

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.