Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows 7 desktop machine, having a static 192.168.*.* IP address on a network full of things with such addresses. I recently received a piece of hardware that I need that machine to talk to over UDP, and that piece of hardware has a built-in IP address of 10.*.*.*. So I went into my desktop's Internet Protocol Version 4 (TCP/IPv4) Properties dialog, clicked Advanced, and added a static 10.*.*.* address (on the same network card as my 192.168.*.* address, which is the only network card I have). That successfully allowed my desktop to talk to the new piece of hardware.

However, I later noticed that a backup script running on a different machine was no longer able to access my desktop. It tries to access my desktop as a network share, like \\desktopname\\foldername. A little poking around revealed that that machine now considers "desktopname" to refer to the 10.*.*.* address that I set up, and it has no way to get to network, so it fails to get to my desktop.

That other machine is running Windows 2003 Server, and it does various things like DNS and DHCP for our network, and probably other Windows networking stuff that is essentially magic from my point of view (I'm just a programmer, not a sysadmin).

I assume that my desktop computer has announced that it is 10.*.*.*, either upon being asked by the server or just of its own volition.

I don't want any computer on the network to think that my desktop is 10.*.*.*. I want them all to keep thinking it's 192.168.*.*. The only reason I put added the 10.*.*.* address was to enable my computer to talk to that one particular piece of hardware; I don't want to have to go around to every computer on the network and give them all access to 10.*.*.*.

How can I get my computer to announce itself as 192.168.*.*, rather than 10.*.*.*? Or, if it announces both, to let other computers know that 192.168.*.* should be treated preferentially? I don't even know what "announce itself" really means. What sort of network discovery service or whatever might this be happening on?

share|improve this question
    
Some things apparently got changed due to being considered markup: By "192.168..", I meant "192.168.something.something"; "10...asterisk" means "10.something.something.something"; "backslash desktopname backslash foldername" means "backslash backslash desktopname backslash servername". –  Grogg Feb 1 '12 at 15:56

2 Answers 2

You have Windows NT version 6.1 on your workstation. In Windows NT 5.0 and later the DHCP Client service on the workstation automatically registers each network connection in the database of the appropriate DNS server, using the Dynamic DNS Update protocol. This registration is configurable per connection, but only to the extent that it can be turned wholly on or wholly off. If a single network connection has multiple IP addresses, the DHCP Client will register either all of them or none of them.

You have both your 192.168.0.0/16 and your 10.0.0.0/8 addresses on a single network connection. The DHCP Client on your workstation is thus registering both of them with the DNS server on your LAN, resulting in lookups for your workstation's name mapping to both IP addresses. The setting controlling this is on the user interface dialogue that you've already found, under the DNS tab. Your checkbox labelled Register this connection's addresses in DNS is checked, you'll find. You need it not to be.

The magic incantation that you need to tell your network administrator is this:

I have two statically assigned IP addresses in two distinct subnets on one NIC. They are 192.168.0.0/16 and 10.0.0.0/8. I have to turn off automatic registration of the forward lookup A resource records for this NIC, because I don't want the 10.0.0.0/8 address to be registered by my workstation. It messes up access to my network shares by other workstations.

Please add a static A resource record to the forward lookup zone on the DNS server for my machine. Its host name is insert your machine's name here, its domain suffix is insert the domain suffix from the TCP/IP properties here, and the statically assigned IP address is insert the 192.168.x.y IP address here.

You'll probably also need to delete the two currently registered A resource records that my workstation has already registered.

You can point your network administrator to the reams of Microsoft doco on this subject, if you like.

Further reading

share|improve this answer
    
scientific career, eh? –  the-wabbit Feb 1 '12 at 19:13

The computer name is getting registered in DNS automatically. Either it is registering the wrong address, or it is registering both addresses - nslookup or checking DNS on your Windows Server should confirm which.

Simplest solution would be to switch off automatic registration of the computer in DNS (it's in the properties for the network connection near where you set up the second IP address), remove erroneous entries in DNS, then manually add the entry you want. After your client DNS caches have cleared, you should get what you want.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.