Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an Exchange Server running Exchange 2010. I have one specific user who we just migrated over to Windows 7 x64 an he is also running Microsoft Outlook 2010 x86. Our exchange mailboxes are tied directly to their Active Directory accounts, so they do not need a password to open Outlook.

Now the problem that only one of my users is running in to. Every 30 minutes or so he gets a notification down in the status bar at the bottom of Outlook that Outlook needs his password. He clicks on the notification button and his mailbox updates. I have no idea what is causing this.

I have tried renaming the profile under: %userprofile%\AppData\Roaming\Microsoft\Protect but this did not resolve my issue.

I have searched high and low for a solution and nothing seems to be relevant.

Thanks for your help in advance.

share|improve this question

4 Answers 4

up vote 1 down vote accepted

I had the same problem not so long ago. Took me 6 months to fix this :)

By GPO you need do disable "Outlook Anywhere". Outlook jumps between TCP and HTTPS/RPC for no reason, and HTTPS/RPC asks for a password.

http://blogs.technet.com/b/outlooking/archive/2010/01/12/configure-outlook-anywhere-settings-for-all-users-via-group-policy.aspx

Disabling "outlook anywhere" in outlook directly will fix the issue until the next reboot, then outlook will reset it to the default as requested by the Exchange Server.

share|improve this answer
1  
Disabling it does not fix the issue, as you obviously have problems with HTTP sessions not being transparent/keepalived. It does however "fix" the problem for the end user. –  pauska Feb 1 '12 at 17:13
    
I'm all open for a better solution. I tried playing with auth on IIS, like every blog talks about, nothing worked. –  Sirber Feb 1 '12 at 17:26
    
Changing the auth method to Windows Integrated on the RPC vdir should stop the prompting for your users. However there are many considerations you need to take into account before doing this. It may not be an option for you. TMG/ISA frontends need special consideration/setup when attempting this. Also, this will change how your users use Outlook Anywhere, I.E. a domain will be required when logging in. Etc. –  Tatas Feb 1 '12 at 17:37
    
that didn't fix the problem for me. Outlooks acts the same (randomly asking password) –  Sirber Feb 1 '12 at 17:52
1  
You lead me down the right path that fixed my issue. You do not need to use a GPO to disable Outlook anywhere though, you can just disable it from the EMC. –  Nic Young Feb 6 '12 at 15:01

This is often seen with load-balanced Exchange deployments where the layer 7 traffic isn't fully transparent.

Try to disable Exchange over HTTP (in the Outlook profile) and see if that helps.

share|improve this answer
    
It will, but exchange will enable it back later on. –  Sirber Feb 1 '12 at 17:28

This may be totally unrelated, but we had a similar issue that I will share. Maybe it will help someone else anyway. A user was frequently asked for her credentials when Outlook (2007) was open, but it was more random than every 30 minutes, not consistent. This went on for months before I realized that she had been issued an Android phone that was set to automatically check her mail. When her desktop and the phone tried to talk to the server at the same time the issue would occur. We set the phone to not sync automatically during business hours and havent had the problem since.

Good luck.

share|improve this answer

Check that you can ping the Exchange Server name from the client. It could be that your Exchange Server Host (A) record is no longer in DNS....but that other clients still have it cached.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.