Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to get click to call to work using Qutecom for a softphone and a Greesemonkey script to turn phone numbers into clickable urls. Whenever I click on the phone number link I get an error message saying the following:

Firefox doesn't know how to open this address, because the protocol (tel) isn't associated with any program.

How would I go about associating Qutecom, or any other softphone, with that link? The Greasemonkey scribt can be found at the link below:

http://userscripts.org/scripts/show/56262

Any help would be greatly appreciated.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

MozillaZine has a page describing how to add new protocol handlers here. On Windows, it looks like it just amounts to a couple minor modifications to the registry. Open Notepad and paste in the following:

REGEDIT4

[HKEY_CLASSES_ROOT\tel]
@="URL:Custom Telephone Protocol for Qutecom VoIP Softphone"
"URL Protocol"=""

[HKEY_CLASSES_ROOT\tel\shell]

[HKEY_CLASSES_ROOT\tel\shell\open]

[HKEY_CLASSES_ROOT\tel\shell\open\command]
@="\"C:\\Program Files\\qutecom\\qutecom.exe\" -c \"call\\%1\"" 

Save the file with a .reg extension (e.g. tel-url.reg). You will need to actually type out the .reg, otherwise Notepad will assume .txt. You can then import these settings into the PC's registry by double-clicking on the file you just created. I don't know if Firefox reads these registry keys directly, or if it depends on Explorer for that, so it's possible that you may need to restart Windows for the change to take effect.

The process for Mac and Linux is different, and involves setting the following preferences in Firefox itself:

  • network.protocol-handler.external.foo
  • network.protocol-handler.app.foo
share|improve this answer
    
Thanks. I'm still not having any success. I try to launch for the command line with; "c:\program files\qutecom\qutecom.exe" -c call\19999999999, but it only opens the app. No number is dialed. QuteCom documentation says that the command to dial is qutecom -c call\123456. Any suggestions? –  Arthur Feb 2 '12 at 18:35
    
If you're on Windows, the command registry entry probably needs to look like @="\"C:\\Program Files\\qutecom\\qutecom.exe\" \"-c\" \"call\\%1\"". –  James Sneeringer Feb 2 '12 at 20:49
    
I apologize, but I'm new to this. When I enter it in like that into the command line, I get an error saying "The filename, directory name, or volume label syntax is incorrect". I set up everything through regedit. It seems like you might have done it through the command line. Maybe that is where the confusion is coming from. –  Arthur Feb 2 '12 at 21:49
    
I've updated my answer to include the additional information you provided. I hope my answer is clearer now. –  James Sneeringer Feb 2 '12 at 22:53
    
I got it working for a few calls, but then it stopped. Now, it seems like the browser is passing "tell:" along with the number. I tried tel:1111111111 in Firefox and Explorer and each has the same problem. The error message it gives is user/number not found tel:+1111111111. If I issue the command from the command line, QuteCom dials the number just fine. Thanks for your help. It looks like it will be another day of fiddling for me. –  Arthur Feb 3 '12 at 4:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.