Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to achieve what is described under:

Webmin In A Sub-Directory Via A Proxy

on this website

Webmin under Apache Guide

...but, with more than one webmin (all on different servers, but proxied thru the main server), arranged into folders, like:

  1. www.example.com/webmin1
  2. www.example.com/webmin2

and so on and so forth.

With one webmin, using a file I created called "webmin.conf" under the "/etc/apache2/conf.d" folder, I have the following code:

ProxyPass /webmin1/ http://internalip:10000/
ProxyPassReverse /webmin1/ http://internalip:10000/
ProxyPass /webmin2/ http://internalip2:10000/
ProxyPassReverse /webmin2/ http://internalip2:10000/
<Proxy *>
allow from all
</Proxy>

This only works with either one of these enabled, but not both.

Please, I'd like some insights. I am a beginner at proxypass, and directives - only 16 years old, trying to figure this stuff out.

Thanks for any and all help!

share|improve this question
    
What's the failure when both are enabled? Browser errors, or web server errors? Anything in Apache's error log? –  Shane Madden Feb 2 '12 at 2:30
    
The failure is odd - I can only log into one of the webmins. I should have specified. –  Connor McBrine-Ellis Feb 2 '12 at 2:49
    
where is the error log? perhaps there is none, if apache starts normally (which it does, when both are enabled) –  Connor McBrine-Ellis Feb 2 '12 at 2:49
    
Debian Apache2 errors are stored in /var/log/apache2/error_log by default, I believe. –  Kyle Smith Feb 2 '12 at 3:46
    
Maybe if I put both of them in Location tags it would work? –  Connor McBrine-Ellis Feb 2 '12 at 19:23

1 Answer 1

Ok I figured it out!

There was a setting in the webmin web server (miniserv) in miniserv.conf that was preventing me from logging in.

There were two port settings and they were set to two different things for some reason. I fixed the setting, and we were back in business!

Thanks for the comments and help anyways, folks.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.