Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I faced some issues in loading COM component through a WebService because the user hadn't permission for C:\Windows\system32\inetsrv\config\schema folder. When I opened the file using Windows Explorer, it has changed the permission and added Users group and the current user to access the folder. This has solved my issue but I need isolate this to confirm.

I tried removing IIS from the box (including the management console). But C:\Windows\system32\inetsrv\ folder exists and being used by SMSvchost and svchost within the system how can I completely remove the IIS from my system? I believe a reinstall would help to restore the old privileges back to the C:\Windows\system32\inetsrv\config\schema folder and files. I think the folder requires permission from "Trusted Installers" group.

I'm running Windows Server 2008 R2 in my box.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I did it using buit-in takeown and cacls utilities.

http://www.howtogeek.com/howto/windows-vista/how-to-delete-a-system-file-in-windows-vista/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.