Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a Novell LDAP server running on RHEL. and I want to authenticate my LDAP users from the Website on one of my machine having HTTP, so I use in the httpd.conf

<Directory /var/www/html>
   AuthType Basic
   AuthName "Stooges Web Site: Login with user id"
   AuthBasicProvider ldap
   AuthzLDAPAuthoritative off
   AuthLDAPURL "ldaps://ldap1.server.com:636/o=ae-name?cn"
   AuthLDAPBindDN "cn=psg_admin,o=ae-name"
   AuthLDAPBindPassword ldappass
   require valid-user

</Directory>

the error I recieve is ......

[31231] auth_ldap authenticate: user ldap-user1 authentication failed; URI / [LDAP: ldap_simple_bind_s() failed][Invalid credentials]
[Thu Feb 02 08:04:39 2012] [error] [client 10.231.101.113] user ldap-user1: authentication failure for "/": Password Mismatch

Is there anything missing or am I making any mistake please guide me in this respect.

share|improve this question

1 Answer 1

It looks like you are not passing in a user name to authenticate with. From the "authentication failure for "/"" bit.

What are you seeing in DStrace on the eDirectory server, with the LDAP trace tag enabled?

Go to the server:8008 and you should be prompted to login (or it might be on 8028, depends on what eDirectory is running on. Or 8010).

If you authenticate, change the url to /nds/trace and you there is a configure button. Clear All, select LDAP, switch to Trace Live (lightning bolt icon) and see what happens on the server end when you try to connect.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.