Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top


I keep getting a warning when I use some php regex functions that says "this version of PCRE is not compiled with PCRE_UTF8 support." I have been digging pretty deep and think that all I need to do is install PCRE from source while the option --enable-utf8 when configuring PCRE. No problem. But then I need to tell PHP to find this new PCRE library. I think I have to install PHP from source and specify an external PCRE library as stated here:

I think specifying the external PCRE library will involve just adding an option when when i do ./configure

If there is a way to do this while using aptitude? I need to set options when aptitude does the ./configure.


share|improve this question

This seems slightly unusual as I would assume php would come with a Unicode version of the library. What distribution / version of PHP are you using?

You can always get the source package for php (apt-get source php5) and the build dependencies (apt build-dep php5) and then just configure and install as you've mentioned above.

share|improve this answer
i agree this is strange. i am using PHP 5.2.4-2ubuntu5.6. the thing i am not understanding is that EVERYONE using wordpress2.8 on ubuntu should be experiencing this issue and there is no easy solution. – Tony Jul 3 '09 at 22:14

You have to use PHP higher than 5.2.4. They have fixed this bug in 5.2.5. It says:

Upgraded PCRE to version 7.3 (Nuno)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.