Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to upgrade ruby and rails gem on a server with cPanel, to do this I installed rvm and I successfully installed different versions of ruby... great stuff!

Having a problem though, the server seems to be ignoring which gemset to use. After installing a fresh copy of 1.9.2 I still get the same list of gems, and the GEM_PATH/GEMHOME is the same:

$>gem env

RubyGems Environment:
– RUBYGEMS VERSION: 1.8.15
– RUBY VERSION: 1.9.2 (2011-07-09 patchlevel 290) [x86_64-linux]
– INSTALLATION DIRECTORY: /home/ruby/ruby/gems
– RUBY EXECUTABLE: /home/ruby/.rvm/rubies/ruby-1.9.2-p290/bin/ruby
– EXECUTABLE DIRECTORY: /home/ruby/ruby/gems/bin
– RUBYGEMS PLATFORMS:
– ruby
– x86_64-linux
– GEM PATHS:
– /home/ruby/ruby/gems
– GEM CONFIGURATION:
– :update_sources => true
– :verbose => true
– :benchmark => false
– :backtrace => false
– :bulk_threshold => 1000
– “gem” => “–remote –gen-rdoc –run-tests”
– “gemhome” => “/home/ruby/ruby/gems”
– “gempath” => []
– “rdoc” => “–inline-source –line-numbers”
– REMOTE SOURCES:
– http://rubygems.org/

Creating new gemsets and trying to use the new gemset doesn't change anything

Would love to get this working, an ideas what I could do to solve this?

P.S: I understand this will break the "ruby on rails" feature of cPanel and users will have to use the shell prompt to generate an app.

~]# rvm list

rvm rubies

   ruby-1.8.7-p357 [ x86_64 ]
=* ruby-1.9.2-p290 [ x86_64 ]

# => - current
# =* - current && default
#  * - default
share|improve this question
    
Should this be moved to stackoverflow? –  Abe Petrillo Feb 3 '12 at 22:09
1  
check to make sure 1.9.2-p290 is default ruby with rvm list ! and also make sure you don't have .rvmrc from previous installation ! –  kaji Feb 11 '12 at 6:15
    
No previous installation to speak of –  Abe Petrillo Feb 11 '12 at 15:09
    
can you put output of rvm list command and rvm version –  kaji Feb 12 '12 at 5:33
    
Edited answer to include rvm-list output –  Abe Petrillo Feb 13 '12 at 0:51

1 Answer 1

up vote 4 down vote accepted
+50

looks like you specify some settings in ~/.gemrc:

    - "gem" => "--remote --gen-rdoc --run-tests"
    - "gemhome" => "/home4/onezerh4/ruby/gems"
    - "gempath" => []
    - "rdoc" => "--inline-source --line-numbers"

you need to remove at least the gemhome and gempath entries from ~/.gemrc

also note that you do not need to add --remote to gem

share|improve this answer
    
You may be on to something "gem list' starts off with the output REMOTE GEMS –  Abe Petrillo Feb 13 '12 at 0:52
    
Yep, that fixed my problem. 50 reputation well earned :) –  Abe Petrillo Feb 13 '12 at 1:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.