Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've noticed that all of the address with the exception of the street address is copied when copying an Active Directory user account. Is there a way to change this? We're currently running a 2003 AD on 2008 DCs and will eventually upgrade the domain level when we activate our new exchange server.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

To have an attribute be included in a copy, you must modify the schema for that attribute - always be very, very careful with schema modifications.

Find the attributeSchema object for the attribute you want to modify in the Schema partition (ADSIEdit is probably the simplest tool to accomplish this), and modify its searchFlags attribute.

It's a bit field, the 0x10 bit is what you'll want to set without modifying what's already there. Verify that the flag isn't already set (if it is, then you'll unintentionally turn off copying and turn on tuple indexing - if you're not familiar with bit fields, do a bit of light reading first), then add 16 to the integer value in the attribute to enable copying.

share|improve this answer
    
Thanks, I figured it was something related to the schema, which I don't think I'll be editing, but it's nice to know how to do it if it ever bothers me enough. :) –  Shawn Feb 3 '12 at 20:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.