Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed icinga from the icinga own repos on my debian squeeze box but now I don't know how to change the current config:

# apache configuration for icinga

  ScriptAlias /cgi-bin/icinga /usr/lib/cgi-bin/icinga
  ScriptAlias /icinga/cgi-bin /usr/lib/cgi-bin/icinga

# Where the stylesheets (config files) reside
  Alias /icinga/stylesheets /etc/icinga/stylesheets

# Where the HTML pages live
  Alias /icinga /usr/share/icinga/htdocs

    <DirectoryMatch (/usr/share/icinga/htdocs|/usr/lib/cgi-   bin/icinga|/etc/icinga/stylesheets)>
      Options FollowSymLinks

      DirectoryIndex index.html

      AllowOverride AuthConfig
      #Order Deny, Allow
      Deny from all
      #Allow From 10.42.0.0/24

      AuthName "Icinga Access"
      AuthType Basic
      AuthUserFile /etc/icinga/htpasswd.users
      require valid-user
    </DirectoryMatch>

I want to run icinga under the subdomain monitoring.mysite.com but I fail to make this config a working vHost config. Is there anybody out who can say what I have to change?

share|improve this question

1 Answer 1

Maybe because there is no VirtualHost, ServerName or DocumentRoot directives?

Replace the asterisk with IP depending on your configuration, however, the asterisk is standard procedure.

# apache configuration for icinga
<VirtualHost *:80>
    ServerName monitoring.mysite.com
    DocumentRoot /usr/share/icinga/htdocs

    ScriptAlias /cgi-bin/icinga /usr/lib/cgi-bin/icinga
    ScriptAlias /icinga/cgi-bin /usr/lib/cgi-bin/icinga

    # Where the stylesheets (config files) reside
    Alias /icinga/stylesheets /etc/icinga/stylesheets

    # Where the HTML pages live
    Alias /icinga /usr/share/icinga/htdocs

    <DirectoryMatch (/usr/share/icinga/htdocs|/usr/lib/cgi-bin/icinga|/etc/icinga/stylesheets)>
        Options FollowSymLinks

        DirectoryIndex index.html

        AllowOverride AuthConfig
        Order Deny, Allow
        #Deny from All
        #Allow From 10.42.0.0/24

        AuthName "Icinga Access"
        AuthType Basic
        AuthUserFile /etc/icinga/htpasswd.users
        Require valid-user
    </DirectoryMatch>
</VirtualHost>
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.