Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For years, I have used vshadow + robocopy to backup data partitions to a remote iSCSI volume. This has been a very efficient method.

This has allowed me to have a "perfect" copy. Open files are copied without any problem, as well as ACLs and everything. In case of a major disk fault, I just have to plug the remote disk in as a replacement for the faulty one. This is much faster than recovering from a backup. I only have the last backup on remote disk. Other backups are done with Backp Exec in a more traditional way, with rotation, etc.

My problem is: I have never managed to do a working backup of a live Windows system partition.
I tested with Windows 2003.

I tested tons of possibilities. Once restored, all of them made it to the prompt to press Ctrl+Alt+Delete to log in. When I enter the username and password, nothing happens. The desktop never appears; there is no error message, just a screen with a uniform color. The machine is up, the services are up (even TSE is okay, but I can't login), the machine responds to pings, etc. But, there is no way to log in.

Example of what I did:

  1. I use identical disks
  2. I duplicate the source disk with dd, to the destination disk (this allow to have the bootloader, the same partition, etc, just to be 100% sure)
  3. I start the source computer
  4. I attach the remote destination disk with iSCSI (also done with a local disk: nothing better). Mapped to drive H:
  5. I take a snapshot of the source disk, and map it to a drive letter:

     vshadow.exe -p c:\
     vshadow -el={edbed95e-7e8d-11d8-9d01-505054503030},g:
  6. I copy the files:

     robocopy g:\ h:\ /mir /is /it /copyall /r:0 /x /v /fp /np /log:c:\robocopy.log /xd "g:\System Volume Information" g:\windows\Prefetch /xf g:\pagefile.sys g:\hyberfile.sys
  7. I look at the generated log: no error, no warning

  8. I stop Windows
  9. I plug the destination disk in place of the previous local disk
  10. I boot, but I can't login

I also tested without copying the registry. There was no improvement.

Is there a way to solve this problem ?

share|improve this question
You are aware of the fact that the only supported way of doing a backup of the Windows Server 2003 boot volume includes a system state backup which needs to be restored along with the volume files? This is especially true for Domain Controllers in a replicated environment. Since the mainstream support phase has ended for Windows Server 2003, you might not care much though. – the-wabbit Feb 3 '12 at 22:55
If we had to rely only on supported things by vendors, few things could be done. For example dd is not a supported way for that, but it works. As well DriveImageXML, xxclone, and many more. – Gregory MOUSSAT Feb 3 '12 at 23:29
Are your credentials being accepted once you try to login and it just sits after? – JMeterX Aug 13 '12 at 13:03
@JMeterX: No error message. The login window disappear and nothing after that. – Gregory MOUSSAT Aug 13 '12 at 18:44
This actually isn't a particularly good way to do backups, but whatever. As suggested in the (edited) answer, use the /B flag to enable backup mode and see what happens. – HopelessN00b Aug 15 '12 at 4:53
up vote 3 down vote accepted

I ran into this problem years ago. This was just the registry settings of the current account which induced problems.

You can create another admin account prior to backing up, and then use it to log in once the backup is made. This solved my problem. I even found the regular admin account worked once I had first logged in with the secondary account (but not before). I don't understand how this is possible.

share|improve this answer
It was so simple. Many thanks ! – Gregory MOUSSAT Aug 19 '12 at 1:26

Since you are able to get to the login screen but the shell doesn't actually come up, I would suspect that something in the user profiles is not being copied properly.

You can try deleting (or not copying) the profile directory that you are trying to log into before starting the copied system. Winlogon should create a fresh profile from the default, assuming that copied OK.

There may be a problem with symlinks, which profiles use heavily. Try robocopy with the /SL flag to copy the link instead of following it to the contents.

There may be a problem with copying the mandatory integrity labels. You didn't mention what account the copy is occurring under; even a member of the Administrators group can't set an integrity level higher than High, but many OS files are System level (which is higher than High). Try running robocopy as NT AUTHORITY\SYSTEM.

Try using the /B flag with robocopy; it uses backup mode, which will copy other metadata like extended attributes and alternate data streams.

Your backup copy may not be very space efficient since versions from at least Vista use hardlinks heavily in the Windows directory for duplicated files (like in SxS) but AFAIK robocopy isn't aware of these and will make a separate copy of each reference to the files.

Are there any errors in your robocopy log?

EDIT: I guess I should have read the description more carefully. Half the things I mentioned don't apply to WS2003, only Vista and later. I've successfully copied whole, running WS2003 systems with a volume shadow copy and robocopy in the past and didn't have login problems. The only difference I can think of offhand is that I used the /B flag to enable backup mode during the copy.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.