Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to get back into the unix game for some storage projects we have got going. We would love to use joyents smartos (based on illumos) for that.

Working with it is a real joy (setting up vms etc) but i can't get iscsi to work.

I would love to simply share a zfs device as an iscsi connection point but cant get it to work. I also cant get smb or nfs to work, but those properties at least exist and i am sure they would work.

The documentation i can find seems a little all-over-the-place with some old solaris, new solaris, illumos stuff etc. Which is understandable since it is such a new release though.

Does anybody have any pointers ?

I already tried

zfs set shareiscsi=on zones/name

which results in "unknown property". And its not listed in the zfs properties anyway.

I also tried

sbdadm create-lu /dev/zvol/rdsk/zones/

but this results in

sbdadm: unknown error

itadm also is not available and not service containing iscsi is listed in "svcs".

Any help is greatly appreciated.

share|improve this question

Creating an ISCSI Target

enable the storage server and iscsi target server if necessary

svcadm enable stmf
svcadm enable -r svc:/network/iscsi/target:default

create a volume if necessary (sparse 10T in example)

zfs create -V 10T -s zones/iscsi

create a logical unit

sbdadm create-lu /dev/zvol/rdsk/zones/iscsi

Add a view on it (GUID is output by previous command or list-lu)

stmfadm add-view GUID

Create a target group to connect to (Choose a GROUPNAME and use an IP from the current server)

itadm create-tpg GROUPNAME IP

Create a target in this group

itadm create-target -t GROUPNAME 
share|improve this answer

It is working with the February 2012 version of SmartOS. The Jan version was missing drivers.

BTW: When writing the Feb 2012 live image of SMARTOS to a usb stick it seemed to be authored incorrectly. The grub file was looking for files in a platform subfolder which did not exist. Simply create it and move the corresponding folder into it (see grub file)

share|improve this answer
You should edit your original answer to provide more information. Serverfault isn't a traditional forum. Read our FAQ for more information on how it's different. – Tom O'Connor Feb 10 '12 at 10:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.