Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am following this guide on how to set up a mail server, Postfix, and one of the assumptions is that I should have an MX record for mail.mydomain.com. Postfix Guide However, I only have an MX record for mydomain.com, and when I try to DiG it, nothing appears.

I have set up everything, and it works, but it is a little bit alarming, I can telnet into localhost 25 and send an email from anybody with the command mail from: anybody@anywhere.com, and it gets sent without incident. It also displays the recipients as undisclosed recipients.

Do I need to somehow get an MX record for mail.mydomain.com? If so, how do I do that?

share|improve this question
    
The second paragraph is completely unrelated. It is also expected behavior; this is called an "open relay". Normally you'd require some kind of authentication for any external access, and possibly internal access. Most properly configured mail servers will mark your fake emails as spam, since they see that you're not the domain of the sender and you have nothing showing legitimacy. –  Michael Lowman Feb 5 '12 at 18:50
    
Thanks, having never set up an email server, I was just posting behavior I wasn't expecting. –  Cayetano Gonçalves Feb 5 '12 at 19:02

1 Answer 1

up vote 8 down vote accepted

You usually want to receive mail for address@mydomain.com, not for address@mail.mydomain.com, so an MX entry for mydomain.com will be sufficient, which usually should point to mail.mydomain.com to enable your mail server as an MX.

share|improve this answer
    
Thank you, that clears up quite a bit of confusion then! –  Cayetano Gonçalves Feb 5 '12 at 19:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.