Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am setting up mencoder on CentOS and I have the following error:

[flv @ 0x86751c8]Unsupported video codec (7) IMediaObject ERROR: 0x8724f4c input format not accepted (0x80040205 : -2147220987) Win32 LoadLibrary failed to load:, /usr/local/lib/codecs/, /usr/lib/win32/, /usr/local/lib/win32/ Warning: DS_Filter() could not open DirectShow DLL. (

I am going through codecs on and none seem to contain

Any ideas how to fix this?


share|improve this question
up vote 1 down vote accepted

Codecs are available on underneath the Binary Codec Packages section. It contains per

share|improve this answer
Thanks for your reply. I downloaded several codec packages from that page and none of them contained It appears that Windows Media Audio 9 Speech DShow is missing. – Alex L Jul 3 '09 at 21:25
Have you tried installing the Win32codecs-essential pack for your architecture? It should contain the files which are needed. You could also try downloading the source for the w32codec-all and extract it to /usr/lib/win32, after that create symlinks to it in /usr/lib/codecs and /usr/local/codecs. – Jeremy Viet Jul 3 '09 at 22:36
Yes, I have tried it but they do not contain I tired win32codecs-20040703.tar.bz2.tar win32codecs-essential-20040703.tar.bz2.tar all-20071007.tar.bz2.tar essential-20071007.tar.bz2.tar None of the packages have How could mplayer say that that codec is supported but not have it in the packages? – Alex L Jul 4 '09 at 15:00

I updated mencoder to the latest version (via SVN) and do not receive this error. Duh..

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.