Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Server 2008 R2 based Active Directory domain. Our default GPO has a few printer/network drive maps that both work fine locally for clients running Windows 7 as well as Windows XP (after applying KB943729). We are currently trying to put some remote offices that do not have local DC's on our domain (connected over site-to-site VPN) and are running into an issue where only machines running Windows 7 are able to pull down these policies and apply them to the local machine. Windows XP clients on the other hand completely ignore the drive/printer map policies. If I try to load rsop.msc on an affected Windows XP client I get an "Invalid Namespace" warning and I can't even see the policy. I have tried:

  • re-joining an affected machine to the domain (does nothing)
  • Disabling Slow Link Detection on both user/computer policies (does nothing)
  • Confirming that the user logged in has rights to the SYSVOL share on the DC. (all Authenticated Users do)

Is there something that I am missing here? I know that putting a local DC in every office would probably fix the issue but we don't have that kind of money to spend right now.

share|improve this question
    
Can your remote XP machines resolve the name of your DC's? –  tegbains Feb 6 '12 at 7:43
    
Have you turned off RSoP logging by any chance? –  the-wabbit Feb 6 '12 at 12:17

1 Answer 1

up vote 0 down vote accepted

I'd recommend enabling debugging in UserEnv to see what kind of hay you can make from that log.

The "Invalid Namespace" error smacks of a problem with WMI. Are you able to see any results in the RSoP snap-in (I'm not clear what you mean when you say "I can't even see the policy".)

share|improve this answer
    
That was exactly what I needed. DSGetDC was failing and after some research I found there a registry key that I had to edit to turn off slow link detection. Thanks!! –  Justin Feb 6 '12 at 22:11
    
Glad to hear I could help you out. –  Evan Anderson Feb 7 '12 at 15:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.