Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

working on an app in node.js, On the test server (debian 2.6.32-5) it works flawlessly, on CentOS 5.7 I get an error.

using the curlrequest node.js library, and the error that comes up is "failed to initialize". I tested curl from the command line and it works fine. I'm thinking it might be a permissions problem?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The issue was with --no-keepalive being used in the curlrequest package. The version of curl that is installed on the CentOS machine doesn't support it. Removing that solved the problem.

share|improve this answer
    
this issue has been solved in the latest version of the curlrequest package –  Last Rose Studios Feb 9 '12 at 19:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.