Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a QNAP TS-659 Pro+ Turbo NAS in our office. Its hardware/software is:

  • 6x SATA II HDD (total 4.5 TB)
  • Intel Atom D525 1.8GHz
  • 1GB DDR2
  • Firmware - 3.5.2 Build 1126T (latest available)
  • Linux 2.6.33.2

Most of the time it works fine but after 1-2 weeks something happens and Samba deamon (smbd) causes 100% CPU usage but when I look into the NAS administration I see almost no bandwidth usage. It just stucks and refuses to do anything.

I tried to kill all processes with high cpu usage but when I opened some file it stucks again (one or more smbd processes with very high cpu usage). The only thing that works is to reboot NAS and then it works for another week or two.

Has anyone encountered a similar problem?

share|improve this question
    
are you using it with VMware? I have the same issue. Moved the VHD's to a differnt storage device and the problem went away. –  t1nt1n Feb 6 '12 at 11:03
    
No, it's real hardware with native software :) –  Martin Feb 6 '12 at 12:37
    
No, I mean do you have VMWare images store on the qnap via the Isci we have had the problem ii describe with our qnap. The support people told us it was due to the Isci and VMWare moved the vhds off a LUN to another LUN and worked fine. –  t1nt1n Feb 6 '12 at 18:33
add comment

1 Answer

There have been IO performance issues reported in the QNAP forum where IO throughput is reduced under certain conditions (free disk space and free RAM). The related issue is dedicated to linux 2.6.33.2 kernel. This kernel is currently used in all QNAP NAS. In case the above mentioned io perf. issue falls in this category, then a workaround (reported to work) is to get more free disk space (80%+) as well as 180MB of free avail RAM.

one of the detailed threads on this is http://forum.qnap.com/viewtopic.php?f=25&t=51741

Would be good to know if your issue is same as root cause as the reported kernel issue is not fully understood - thus there are many other threads in the qnap forum that report similar behaviour. but since today there is no good understanding( root cause) nor a patch available. Newer kernels do not have this issue any more.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.